summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-11-05 20:06:14 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-11-05 20:06:14 +0000
commit986e856320aade1ff8032e23a49915cc5ead0eaa (patch)
treeb8583838f10ecd3a7cd899a1a4fa3dbc63a98ebb /app-antivirus
parentrev bump. Change the mythtv user to be loginable. Added my MythFrontend autos... (diff)
downloadhistorical-986e856320aade1ff8032e23a49915cc5ead0eaa.tar.gz
historical-986e856320aade1ff8032e23a49915cc5ead0eaa.tar.bz2
historical-986e856320aade1ff8032e23a49915cc5ead0eaa.zip
Version bump. Removed old ebuilds. Depend on either libmilter on sendmail when milter USE flag is on. Closes bug #152541, by Milan Holzäpfel <public at mjh.name>.
Package-Manager: portage-2.1.2_rc1-r1
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog10
-rw-r--r--app-antivirus/clamav/clamav-0.88.6.ebuild112
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.88.63
3 files changed, 124 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 1fcc302ed57e..3937b794c33e 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.176 2006/10/31 01:07:21 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.177 2006/11/05 20:06:14 ticho Exp $
+
+*clamav-0.88.6 (05 Nov 2006)
+
+ 05 Nov 2006; Andrej Kacian <ticho@gentoo.org> -clamav-0.88.2.ebuild,
+ -clamav-0.88.3.ebuild, -clamav-0.88.4.ebuild, +clamav-0.88.6.ebuild:
+ Version bump. Removed old ebuilds. Depend on either libmilter on sendmail
+ when milter USE flag is on. Closes bug #152541, by Milan Holzäpfel <public
+ at mjh.name>.
*clamav-0.90_rc2 (30 Oct 2006)
diff --git a/app-antivirus/clamav/clamav-0.88.6.ebuild b/app-antivirus/clamav/clamav-0.88.6.ebuild
new file mode 100644
index 000000000000..424e483ed84f
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.88.6.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.88.6.ebuild,v 1.1 2006/11/05 20:06:14 ticho Exp $
+
+inherit eutils flag-o-matic fixheadtails
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt milter selinux mailwrapper"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? || ( mail-filter/libmilter mail-mta/sendmail )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/lib/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newconfd ${FILESDIR}/clamd.conf clamd
+ newinitd ${FILESDIR}/clamd.rc clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/freshclam.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/freshclam.conf
+
+ if use milter ; then
+ echo "START_MILTER=no" \
+ >> ${D}/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>${D}/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>${D}/etc/conf.d/clamd
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions how to setup the clamav-milter type:"
+ echo " zless /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.88.6 b/app-antivirus/clamav/files/digest-clamav-0.88.6
new file mode 100644
index 000000000000..c52da2995c36
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.88.6
@@ -0,0 +1,3 @@
+MD5 db7f8b947bc21023f36e04bfdd555dd0 clamav-0.88.6.tar.gz 8929534
+RMD160 efa53c600a70a8f808fbf9cde92ebf193b76e574 clamav-0.88.6.tar.gz 8929534
+SHA256 cc7f90983aa61b3d893c3311e3f832c5faa204467143cff597ad80bf8ad24daa clamav-0.88.6.tar.gz 8929534