summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2011-04-10 22:49:46 +0000
committerJonathan Callen <jcallen@gentoo.org>2011-04-10 22:49:46 +0000
commitd47bfa7e62180cbc3b98f1dbf1ab83ddb06e7b90 (patch)
tree104bc96935931f83b42454cda13ab367361d606e /app-arch/cksfv/cksfv-1.3.14.ebuild
parentFix install in parallel and install of ldap-related files, thanks to Chris Co... (diff)
downloadhistorical-d47bfa7e62180cbc3b98f1dbf1ab83ddb06e7b90.tar.gz
historical-d47bfa7e62180cbc3b98f1dbf1ab83ddb06e7b90.tar.bz2
historical-d47bfa7e62180cbc3b98f1dbf1ab83ddb06e7b90.zip
Add prefix support, bump EAPI to 3, add prefix keywords
Package-Manager: portage-2.2.0_alpha29_p11/cvs/Linux i686
Diffstat (limited to 'app-arch/cksfv/cksfv-1.3.14.ebuild')
-rw-r--r--app-arch/cksfv/cksfv-1.3.14.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-arch/cksfv/cksfv-1.3.14.ebuild b/app-arch/cksfv/cksfv-1.3.14.ebuild
index 527a287129bb..cd35353fd06c 100644
--- a/app-arch/cksfv/cksfv-1.3.14.ebuild
+++ b/app-arch/cksfv/cksfv-1.3.14.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cksfv/cksfv-1.3.14.ebuild,v 1.1 2009/09/05 17:34:49 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cksfv/cksfv-1.3.14.ebuild,v 1.2 2011/04/10 22:49:46 abcd Exp $
+EAPI=3
inherit toolchain-funcs
DESCRIPTION="SFV checksum utility (simple file verification)"
@@ -10,20 +11,19 @@ SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE=""
DEPEND=""
-src_compile() {
+src_configure() {
# note: not an autoconf configure script
./configure \
--compiler=$(tc-getCC) \
- --prefix=/usr \
+ --prefix="${EPREFIX}"/usr \
--package-prefix="${D}" \
- --bindir=/usr/bin \
- --mandir=/usr/share/man || die
- emake || die
+ --bindir="${EPREFIX}"/usr/bin \
+ --mandir="${EPREFIX}"/usr/share/man || die
}
src_install() {