summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-07-01 16:06:06 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-07-01 16:06:06 +0000
commit0920f5552ce4eea5b1d13db979eb711fb3c58d30 (patch)
treeeb21da5cefaa65942a650e3b2925aac291c96810 /app-arch/ipkg-utils/files
parentBump for 2.14.2 (diff)
downloadhistorical-0920f5552ce4eea5b1d13db979eb711fb3c58d30.tar.gz
historical-0920f5552ce4eea5b1d13db979eb711fb3c58d30.tar.bz2
historical-0920f5552ce4eea5b1d13db979eb711fb3c58d30.zip
Some cleanups from James
Package-Manager: portage-2.1.1_pre1-r5
Diffstat (limited to 'app-arch/ipkg-utils/files')
-rw-r--r--app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch b/app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch
new file mode 100644
index 000000000000..c2044db72d77
--- /dev/null
+++ b/app-arch/ipkg-utils/files/ipkg-utils-1.7-build_fixes.patch
@@ -0,0 +1,29 @@
+Index: ipkg-utils-1.7/Makefile
+===================================================================
+--- ipkg-utils-1.7/Makefile {cset 1fe36b83-662c-4d43-b5df-915184007abf}
++++ ipkg-utils-1.7/Makefile {local clone}
+@@ -1,20 +1,19 @@
+ UTILS = ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload
+
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ all: build
+
+ build: ipkg-compare-versions
+- python setup.py build
+
+ ipkg-compare-versions: ipkg-compare-versions.c
+ $(CC) $(CFLAGS) -o ipkg-compare-versions ipkg-compare-versions.c
+
+ install: ${UTILS}
+- cp ${UTILS} $(PREFIX)/bin
+- python setup.py install
++ mkdir -p $(DESTDIR)$(PREFIX)/bin
++ cp ${UTILS} $(DESTDIR)$(PREFIX)/bin
+ chmod agu+rx ipkg-make-index
+- cp -f ipkg-make-index $(PREFIX)/bin
++ cp -f ipkg-make-index $(DESTDIR)$(PREFIX)/bin
+
+ binary: build
+ mkdir -p ipkg-build-binary/usr/bin