summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-11-15 08:52:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-11-15 08:52:29 +0000
commit0a0a28c1d03aa6aad20e13ff0197553ee84dbfb7 (patch)
treeacdc5ca6720eb30215f8bc6627a6c5ba8c9b8c05 /app-arch
parentppm based compressor (diff)
downloadhistorical-0a0a28c1d03aa6aad20e13ff0197553ee84dbfb7.tar.gz
historical-0a0a28c1d03aa6aad20e13ff0197553ee84dbfb7.tar.bz2
historical-0a0a28c1d03aa6aad20e13ff0197553ee84dbfb7.zip
ppm based compressor
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/ppmd/Manifest4
-rw-r--r--app-arch/ppmd/files/digest-ppmd-9.12
-rw-r--r--app-arch/ppmd/metadata.xml10
-rw-r--r--app-arch/ppmd/ppmd-9.1.ebuild36
4 files changed, 51 insertions, 1 deletions
diff --git a/app-arch/ppmd/Manifest b/app-arch/ppmd/Manifest
index f06dc4cebee2..13a39964139f 100644
--- a/app-arch/ppmd/Manifest
+++ b/app-arch/ppmd/Manifest
@@ -1,2 +1,4 @@
-MD5 1cc6811ae14b95bda83d93cde302bed3 ppmd-9.1.ebuild 780
+MD5 ce14aa62246058202ec7eb83192f634f ppmd-9.1.ebuild 916
+MD5 2553e30503a4890239a598aa1a4c4921 ChangeLog 399
+MD5 67c5ee2105083a2b9c14a87b5dbf34f9 metadata.xml 328
MD5 df4579e26fa5a155f60190d373501ab9 files/digest-ppmd-9.1 126
diff --git a/app-arch/ppmd/files/digest-ppmd-9.1 b/app-arch/ppmd/files/digest-ppmd-9.1
new file mode 100644
index 000000000000..6514f6865f05
--- /dev/null
+++ b/app-arch/ppmd/files/digest-ppmd-9.1
@@ -0,0 +1,2 @@
+MD5 35b5f1cecf3df377af196e79182a8659 ppmd_9.1.orig.tar.gz 48508
+MD5 a16713ad8c6e6d21d503026d4a27d8f4 ppmd_9.1-7.diff.gz 76427
diff --git a/app-arch/ppmd/metadata.xml b/app-arch/ppmd/metadata.xml
new file mode 100644
index 000000000000..ecfececa66ac
--- /dev/null
+++ b/app-arch/ppmd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <name>Brian Harring</name>
+ <email>bdharring@wisc.edu</email>
+ <description>Indirectly maintaining through seemant@gentoo.org</description>
+</maintainer>
+</pkgmetadata>
diff --git a/app-arch/ppmd/ppmd-9.1.ebuild b/app-arch/ppmd/ppmd-9.1.ebuild
new file mode 100644
index 000000000000..d6bc50bd23d1
--- /dev/null
+++ b/app-arch/ppmd/ppmd-9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ppmd/ppmd-9.1.ebuild,v 1.1 2003/11/15 08:52:28 seemant Exp $
+
+inherit eutils
+
+IUSE=""
+
+PATCHV="7"
+MY_P=${P/-/_}
+MY_S=${PN}-i1
+S=${WORKDIR}/${MY_S}
+DESCRIPTION="PPM based compressor -- better behaved than bzip2"
+HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/ppmd/"
+SRC_URI="http://http.us.debian.org/debian/pool/main/p/ppmd/${MY_P}.orig.tar.gz
+ http://http.us.debian.org/debian/pool/main/p/ppmd/${MY_P}-${PATCHV}.diff.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64"
+
+DEPEND="app-arch/gzip
+ sys-devel/patch"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${MY_P}-${PATCHV}.diff
+ chmod +x ${S}/configure
+}
+
+src_install() {
+ einstall || die
+ doman ${S}/PPMd.1
+ dodoc ${S}/read_me.txt
+}