summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-11 00:59:24 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-11 00:59:24 +0000
commita0067e3d78176997db332755f746e725436d3fe5 (patch)
tree66509e0a3624afb6435ffa8c632e9a23d6baba13 /app-arch
parentold (diff)
downloadhistorical-a0067e3d78176997db332755f746e725436d3fe5.tar.gz
historical-a0067e3d78176997db332755f746e725436d3fe5.tar.bz2
historical-a0067e3d78176997db332755f746e725436d3fe5.zip
old
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/bzip2-1.0.5.ebuild76
-rw-r--r--app-arch/cpio/cpio-2.9-r1.ebuild39
-rw-r--r--app-arch/makeself/makeself-2.1.4.ebuild29
3 files changed, 0 insertions, 144 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.5.ebuild b/app-arch/bzip2/bzip2-1.0.5.ebuild
deleted file mode 100644
index 61ca8fa0eada..000000000000
--- a/app-arch/bzip2/bzip2-1.0.5.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.5.ebuild,v 1.8 2008/03/24 12:06:36 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="static"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
-
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die "sed links"
-
- # fixup broken version stuff
- sed -i \
- -e "s:1\.0\.4:${PV}:" \
- bzip2.1 bzip2.txt Makefile-libbz2_so manual.{html,ps,xml} || die
-}
-
-src_compile() {
- local makeopts="
- CC=$(tc-getCC)
- AR=$(tc-getAR)
- RANLIB=$(tc-getRANLIB)
- "
- emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
- use static && append-flags -static
- emake LDFLAGS="${LDFLAGS}" ${makeopts} all || die "Make failed"
-
- if ! tc-is-cross-compiler ; then
- # bzip2 is a "core" package and the tests are quick ...
- emake check || die "test failed"
- fi
-}
-
-src_install() {
- emake PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
- dodoc README* CHANGES bzip2.txt manual.*
-
- # move bzip2 binaries to /bin and use the shared libbz2.so
- mv "${D}"/usr/bin "${D}"/bin || die
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
- into /
- if ! use static ; then
- newbin bzip2-shared bzip2 || die "dobin shared"
- fi
-
- dolib.so libbz2.so.${PV} || die "dolib shared"
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /$(get_libdir)/${v}
- done
- gen_usr_ldscript libbz2.so
-}
diff --git a/app-arch/cpio/cpio-2.9-r1.ebuild b/app-arch/cpio/cpio-2.9-r1.ebuild
deleted file mode 100644
index 6ea23e2a692e..000000000000
--- a/app-arch/cpio/cpio-2.9-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.9-r1.ebuild,v 1.9 2007/11/18 02:43:01 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="A file archival tool which can also read and write tar files"
-HOMEPAGE="http://www.gnu.org/software/cpio/cpio.html"
-SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls"
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-CVE-2007-4476.patch #196978
- epatch "${FILESDIR}"/${P}-gnu-inline.patch #198817
-}
-
-src_compile() {
- econf \
- $(use_enable nls) \
- --bindir=/bin \
- --with-rmt=/usr/sbin/rmt \
- || die
- emake || die
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc ChangeLog NEWS README
- rm -f "${D}"/usr/share/man/man1/mt.1
- rmdir "${D}"/usr/libexec || die
-}
diff --git a/app-arch/makeself/makeself-2.1.4.ebuild b/app-arch/makeself/makeself-2.1.4.ebuild
deleted file mode 100644
index 47963c867eb1..000000000000
--- a/app-arch/makeself/makeself-2.1.4.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/makeself/makeself-2.1.4.ebuild,v 1.3 2007/03/30 14:02:34 beandog Exp $
-
-inherit eutils
-
-DESCRIPTION="shell script that generates a self-extractible tar.gz"
-HOMEPAGE="http://www.megastep.org/makeself/"
-SRC_URI="http://www.megastep.org/makeself/${P}.run"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ppc s390 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack_makeself
-}
-
-src_install() {
- dobin makeself-header.sh makeself.sh || die
- doman makeself.1
- dodoc README TODO makeself.lsm
-}