summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2005-03-28 10:30:31 +0000
committerMartin Holzer <mholzer@gentoo.org>2005-03-28 10:30:31 +0000
commitac0e2c0ed12253ac3220d9b19050f9c6afd9a816 (patch)
tree1006af7d11db7df9dd1075940990807985c0a543 /app-arch
parentVersion bumped. Closes 86622 (diff)
downloadhistorical-ac0e2c0ed12253ac3220d9b19050f9c6afd9a816.tar.gz
historical-ac0e2c0ed12253ac3220d9b19050f9c6afd9a816.tar.bz2
historical-ac0e2c0ed12253ac3220d9b19050f9c6afd9a816.zip
Version bumped. Cloeses 79761
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dump/ChangeLog7
-rw-r--r--app-arch/dump/Manifest16
-rw-r--r--app-arch/dump/dump-0.4.39.ebuild66
-rw-r--r--app-arch/dump/files/digest-dump-0.4.391
4 files changed, 76 insertions, 14 deletions
diff --git a/app-arch/dump/ChangeLog b/app-arch/dump/ChangeLog
index 1e4a0d81bb44..3e1f5f60db81 100644
--- a/app-arch/dump/ChangeLog
+++ b/app-arch/dump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/dump
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.37 2005/02/05 19:15:07 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/ChangeLog,v 1.38 2005/03/28 10:30:31 mholzer Exp $
+
+*dump-0.4.39 (28 Mar 2005)
+
+ 28 Mar 2005; Martin Holzer <mholzer@gentoo.org> +dump-0.4.39.ebuild:
+ Version bumped. Cloeses 79761
05 Feb 2005; <solar@gentoo.org> dump-0.4.37.ebuild:
- q/a fix. os-headers are not needed in RDEPEND
diff --git a/app-arch/dump/Manifest b/app-arch/dump/Manifest
index e4261e82f747..7a97ac0bf906 100644
--- a/app-arch/dump/Manifest
+++ b/app-arch/dump/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 e5f699438a4659099728351091772253 dump-0.4.39.ebuild 1548
+MD5 1a34613f215b59e4992929425013cb72 ChangeLog 5567
MD5 7b798cbea6e9a29ae22ece46ce51b41e dump-0.4.37.ebuild 1540
-MD5 058f3646a1fdd150bfc2568e69d97063 ChangeLog 5433
+MD5 918243abb15a1cf0df32c00b42d77b50 files/digest-dump-0.4.39 63
MD5 15319d17b124480af1cb76202c5cb78d files/digest-dump-0.4.37 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iQCVAwUBQgUbHp4WFLgrx1GWAQK+CgP/SDJ8a7fPPNq3FOk+Dv5aH+RT7Dyq33Aq
-f1RVQvCgm6sxeXoHil8cSk4vM2GfhZbMwJif9+UP0sy09B3Zw7iwnubGWFV4L6Qp
-NWDcqfonKgFPAlSln7doaj5W7fqz5RpckxjeW2d/dwalhKMKhNsOSEeucJMWzrnv
-2RPUl9dj8AI=
-=2FOc
------END PGP SIGNATURE-----
diff --git a/app-arch/dump/dump-0.4.39.ebuild b/app-arch/dump/dump-0.4.39.ebuild
new file mode 100644
index 000000000000..db1ecc2262f5
--- /dev/null
+++ b/app-arch/dump/dump-0.4.39.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dump/dump-0.4.39.ebuild,v 1.1 2005/03/28 10:30:31 mholzer Exp $
+
+MY_P=${P/4./4b}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="http://dump.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="readline static"
+
+DEPEND=">=sys-fs/e2fsprogs-1.27
+ >=app-arch/bzip2-1.0.2
+ >=sys-libs/zlib-1.1.4
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}
+ || (
+ app-arch/star
+ app-arch/tar
+ )"
+
+# virtual/os-headers never belong in RDEPENDs
+DEPEND="${DEPEND} virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:-ltermcap:-lncurses:g" configure || die
+}
+
+src_compile() {
+ econf \
+ --with-dumpdatespath=/etc/dumpdates \
+ --with-binowner=root \
+ --with-bingroup=root \
+ --enable-largefile \
+ $(use_enable static) \
+ $(use_enable static staticz) \
+ $(use_enable readline) \
+ || die
+ emake || die
+}
+
+src_install() {
+ # built on old autotools, no DESTDIR support
+ einstall MANDIR=${D}/usr/share/man/man8 || die
+ mv "${D}"/usr/sbin/{,dump-}rmt
+ mv "${D}"/usr/share/man/man8/{,dump-}rmt.8
+
+ dodoc CHANGES KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+ cd examples
+ local d=
+ for d in * ; do
+ docinto ${d}
+ dodoc ${d}/*
+ done
+}
+
+pkg_postinst() {
+ ewarn "Dump now installs 'rmt' as 'dump-rmt'."
+ ewarn "This is to avoid conflicts with tar's 'rmt'."
+}
diff --git a/app-arch/dump/files/digest-dump-0.4.39 b/app-arch/dump/files/digest-dump-0.4.39
new file mode 100644
index 000000000000..529d7b2064c5
--- /dev/null
+++ b/app-arch/dump/files/digest-dump-0.4.39
@@ -0,0 +1 @@
+MD5 843e4cd3cf0024a25a3d2062ade825fe dump-0.4b39.tar.gz 277380