summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2008-11-23 09:46:22 +0000
committerPatrick Lauer <patrick@gentoo.org>2008-11-23 09:46:22 +0000
commitae8fe61fbe526a52285f45f72eeacbf0ac5b44f9 (patch)
treef5f87cc1e34670771071d2df7e513b7604b8c7f5 /app-benchmarks/dbench/dbench-4.0.ebuild
parentVersion bumped. (diff)
downloadhistorical-ae8fe61fbe526a52285f45f72eeacbf0ac5b44f9.tar.gz
historical-ae8fe61fbe526a52285f45f72eeacbf0ac5b44f9.tar.bz2
historical-ae8fe61fbe526a52285f45f72eeacbf0ac5b44f9.zip
Bump to 4.0, fixups on 2.0, benchmark herd taking over the world one
package at a time Package-Manager: portage-2.2_rc14/cvs/Linux 2.6.26.5 x86_64
Diffstat (limited to 'app-benchmarks/dbench/dbench-4.0.ebuild')
-rw-r--r--app-benchmarks/dbench/dbench-4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-benchmarks/dbench/dbench-4.0.ebuild b/app-benchmarks/dbench/dbench-4.0.ebuild
new file mode 100644
index 000000000000..6f6ec94615b5
--- /dev/null
+++ b/app-benchmarks/dbench/dbench-4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/dbench/dbench-4.0.ebuild,v 1.1 2008/11/23 09:46:22 patrick Exp $
+
+DESCRIPTION="Popular filesystem benchmark"
+SRC_URI="ftp://ftp.samba.org/pub/tridge/dbench/${P}.tar.gz"
+HOMEPAGE="http://samba.org/ftp/tridge/dbench/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+inherit eutils autotools
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/${P}"
+ eautoheader
+ eautoconf
+ econf
+ }
+
+src_install() {
+ dobin dbench tbench tbench_srv
+ dodoc README INSTALL
+ doman dbench.1
+ insinto /usr/share/dbench
+ doins client.txt
+}
+
+pkg_postinst() {
+ elog "You can find the client.txt file in ${ROOT}usr/share/dbench."
+}