summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-02-04 15:10:19 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-02-04 15:10:19 +0000
commit1496e3d584fa6e3920e99da5fb40dcf77b351da6 (patch)
treea4cef9f3c9c5c792ac75da7e6cbf14544dc71652 /app-benchmarks/os-autoinst
parentStable for arm, wrt bug #454906 (diff)
downloadhistorical-1496e3d584fa6e3920e99da5fb40dcf77b351da6.tar.gz
historical-1496e3d584fa6e3920e99da5fb40dcf77b351da6.tar.bz2
historical-1496e3d584fa6e3920e99da5fb40dcf77b351da6.zip
Update deps and prune libtool files.
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64 Manifest-Sign-Key: 0x8EEE3BE8
Diffstat (limited to 'app-benchmarks/os-autoinst')
-rw-r--r--app-benchmarks/os-autoinst/ChangeLog7
-rw-r--r--app-benchmarks/os-autoinst/os-autoinst-9999.ebuild20
2 files changed, 18 insertions, 9 deletions
diff --git a/app-benchmarks/os-autoinst/ChangeLog b/app-benchmarks/os-autoinst/ChangeLog
index 027883d0622f..56b303e3d079 100644
--- a/app-benchmarks/os-autoinst/ChangeLog
+++ b/app-benchmarks/os-autoinst/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/os-autoinst
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/os-autoinst/ChangeLog,v 1.5 2012/11/08 13:29:38 scarabeus Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/os-autoinst/ChangeLog,v 1.6 2013/02/04 15:10:19 scarabeus Exp $
+
+ 04 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org> os-autoinst-9999.ebuild:
+ Update deps and prune libtool files.
08 Nov 2012; Tomáš Chvátal <scarabeus@gentoo.org> os-autoinst-9999.ebuild:
Require perl with threads.
diff --git a/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
index f0e10dadac46..0587553dde04 100644
--- a/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
+++ b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild,v 1.4 2012/11/08 13:29:38 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild,v 1.5 2013/02/04 15:10:19 scarabeus Exp $
EAPI=4
EGIT_REPO_URI="git://gitorious.org/os-autoinst/os-autoinst.git"
-inherit git-2 autotools
+inherit git-2 autotools eutils
DESCRIPTION="automated testing of Operating Systems"
HOMEPAGE="http://os-autoinst.org/"
@@ -17,15 +17,15 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-RDEPEND="
+DEPEND="media-libs/opencv"
+RDEPEND="${DEPEND}
dev-lang/perl[ithreads]
+ dev-perl/JSON
app-emulation/qemu
app-text/gocr
media-gfx/imagemagick
media-video/ffmpeg2theora
-
"
-DEPEND=""
src_prepare() {
eautoreconf
@@ -33,5 +33,11 @@ src_prepare() {
src_configure() {
econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
}