summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-12-16 23:36:10 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-12-16 23:36:10 +0000
commit33e1120862b9ad9dcbb67d61f115e3535ef442d5 (patch)
tree084d273ce3971f47228d0b439550e40b55f6c8fa /app-cdr/k9copy/k9copy-2.1.0.ebuild
parentVersion bump. Anki now uses QtWebKit. (diff)
downloadhistorical-33e1120862b9ad9dcbb67d61f115e3535ef442d5.tar.gz
historical-33e1120862b9ad9dcbb67d61f115e3535ef442d5.tar.bz2
historical-33e1120862b9ad9dcbb67d61f115e3535ef442d5.zip
Version bump adding KDE4 release of K9Copy and fixing bug #223909 (thanks Daniel Pielmeier, Theo Chatzimichos and Chris Mayo).
Package-Manager: portage-2.2_rc17/cvs/Linux 2.6.27-gentoo-r5 x86_64
Diffstat (limited to 'app-cdr/k9copy/k9copy-2.1.0.ebuild')
-rw-r--r--app-cdr/k9copy/k9copy-2.1.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-cdr/k9copy/k9copy-2.1.0.ebuild b/app-cdr/k9copy/k9copy-2.1.0.ebuild
new file mode 100644
index 000000000000..ded2de5e8a2e
--- /dev/null
+++ b/app-cdr/k9copy/k9copy-2.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/k9copy/k9copy-2.1.0.ebuild,v 1.1 2008/12/16 23:36:10 tgurr Exp $
+
+EAPI="1"
+
+NEED_KDE="4.1"
+KDE_LINGUAS="ca cs de el es_AR es et fr it nl pl pt_BR ru sr sr@Latn tr zh_TW"
+inherit kde4-base
+
+DESCRIPTION="k9copy is a DVD backup utility which allows the copy of one or more titles from a DVD9 to a DVD5."
+HOMEPAGE="http://k9copy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-Source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="media-libs/libdvdread
+ media-libs/xine-lib
+ >=media-video/ffmpeg-0.4.9_p20081014
+ x11-libs/qt-dbus:4
+ !kdeprefix? ( !app-cdr/k9copy:0 )"
+
+RDEPEND="${DEPEND}
+ media-video/dvdauthor
+ media-video/mplayer"
+
+S="${WORKDIR}/${P}-Source"
+
+src_unpack() {
+ # NOTE: Should be changed once the eclass moving linguas stuff to src_prepare
+ # hits the tree or package gets fixed upstream.
+ kde4-base_src_unpack
+
+ sed -i -e 's/sr@latin/sr@Latn/g' \
+ "${S}"/po/cmake_install.cmake || die "sed failed"
+ mv -i "${S}"/po/sr@latin.po "${S}"/po/sr@Latn.po
+
+ enable_selected_linguas
+}
+
+pkg_postinst() {
+ echo
+ elog "If you want K3b burning support in ${P}, please install app-cdr/k3b separately."
+ elog "If you want phonon media playback in ${P}, please install media-sound/phonon separately."
+ echo
+}