summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-23 10:45:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-02-23 10:45:19 +0000
commit7375b0ccd211ba039eb4cfcc15f1ed9372198aae (patch)
tree8511914d0ae7bdffdbc226fc52b2ce185e9fc89d /app-crypt/ccid/ccid-1.4.2.ebuild
parentTo fully comply with the license, we need to make sure a copy of it ends up o... (diff)
downloadhistorical-7375b0ccd211ba039eb4cfcc15f1ed9372198aae.tar.gz
historical-7375b0ccd211ba039eb4cfcc15f1ed9372198aae.tar.bz2
historical-7375b0ccd211ba039eb4cfcc15f1ed9372198aae.zip
Version bump, remove old versions (which are not compatible with latest pcsc-lite anyway), and also drop 1.4.1-r2 in favour of the new 1.4.2 (which has the original patch applied).
Package-Manager: portage-2.2.0_alpha25/cvs/Linux x86_64
Diffstat (limited to 'app-crypt/ccid/ccid-1.4.2.ebuild')
-rw-r--r--app-crypt/ccid/ccid-1.4.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/ccid/ccid-1.4.2.ebuild b/app-crypt/ccid/ccid-1.4.2.ebuild
new file mode 100644
index 000000000000..3ba2fdf65285
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ccid/ccid-1.4.2.ebuild,v 1.1 2011/02/23 10:45:19 flameeyes Exp $
+
+EAPI="3"
+
+STUPID_NUM="3518"
+
+inherit eutils
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="http://pcsclite.alioth.debian.org/ccid.html"
+SRC_URI="http://alioth.debian.org/download.php/${STUPID_NUM}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="twinserial +usb"
+
+DEPEND=">=sys-apps/pcsc-lite-1.6.5
+ usb? ( virtual/libusb:1 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's:GROUP="pcscd":ENV{PCSCD}="1":' \
+ src/92_pcscd_ccid.rules || die
+}
+
+src_configure() {
+ econf \
+ LEX=: \
+ --docdir="/usr/share/doc/${PF}" \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS || die
+ insinto /lib/udev/rules.d
+ doins src/92_pcscd_ccid.rules || die
+}