summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-04-27 04:36:01 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-04-27 04:36:01 +0000
commit5227b007c5ce05454539f117b2c10ed9bde4283f (patch)
treeee18ef70addfd46d1cd6127c9227c8c6647a66c2 /app-crypt
parentAdded Seahorse, a gnome frontend to gnupg (diff)
downloadhistorical-5227b007c5ce05454539f117b2c10ed9bde4283f.tar.gz
historical-5227b007c5ce05454539f117b2c10ed9bde4283f.tar.bz2
historical-5227b007c5ce05454539f117b2c10ed9bde4283f.zip
Updated gnupg to 1.0.4-r1, added a check for nls, and added SUID on the gpg
binary itself because it needs it for using secure memory.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.0.4-r11
-rw-r--r--app-crypt/gnupg/gnupg-1.0.4-r1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.0.4-r1 b/app-crypt/gnupg/files/digest-gnupg-1.0.4-r1
new file mode 100644
index 000000000000..2d2ff22b164d
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.0.4-r1
@@ -0,0 +1 @@
+MD5 bef2267bfe9b74a00906a78db34437f9 gnupg-1.0.4.tar.gz
diff --git a/app-crypt/gnupg/gnupg-1.0.4-r1.ebuild b/app-crypt/gnupg/gnupg-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..92a9e727e027
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.0.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${A}"
+HOMEPAGE="http://www.gnupg.org/"
+
+DEPEND=">=sys-devel/gettext-0.10.35
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+
+# Check to see if we're using nls
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share \
+ --enable-static-rnd=linux --enable-m-guard --host=${CHOST}\
+ ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc faq.html faq.raw gpg.sgml gpgv.sgml FAQ HACKING DETAILS ChangeLog
+ chmod +s ${D}/usr/bin/gpg
+}
+