summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-05-30 03:07:19 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-05-30 03:07:19 +0000
commitb3038649170f20e25b78e8bdf558be4698f58262 (patch)
tree4588234482ab19e3c69441cf2dc3c58747fd400a /app-crypt
parentfix bogus description (diff)
downloadhistorical-b3038649170f20e25b78e8bdf558be4698f58262.tar.gz
historical-b3038649170f20e25b78e8bdf558be4698f58262.tar.bz2
historical-b3038649170f20e25b78e8bdf558be4698f58262.zip
new version, added --enable-dns and set up --localstatedir=/var/krb5kdc
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/krb5/krb5-1.2.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/krb5/krb5-1.2.5.ebuild b/app-crypt/krb5/krb5-1.2.5.ebuild
new file mode 100644
index 000000000000..ba7f761cf561
--- /dev/null
+++ b/app-crypt/krb5/krb5-1.2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Grant Goodyear <grant@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5.ebuild,v 1.1 2002/05/30 03:07:19 mjc Exp $
+
+S=${WORKDIR}/${P}/src
+SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
+DESCRIPTION="MIT Kerberos V (set up for pam)"
+HOMEPAGE="http://crypto-publish.org"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+
+ patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff
+
+ ./configure --with-krb4 --enable-shared --prefix=/usr \
+ --mandir=/usr/share/man --host=${CHOST} \
+ --localstatedir=/var/krb5kdc \
+ --enable-dns \
+ || die
+ mv Makefile Makefile.orig
+ #Don't install the ftp, telnet, r* apps; use pam instead
+ sed -e 's/ appl / /' Makefile.orig > Makefile
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ cd ..
+ dodoc README
+ echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+
+}
+