summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-06-01 06:09:49 +0000
committerUlrich Müller <ulm@gentoo.org>2007-06-01 06:09:49 +0000
commit047fd1a1ed253626720059e77537c9cdbeebe496 (patch)
tree19a2f3cbfe3cbb56263be3d4442b4ae05a83364d /app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
parentStable on mips. (diff)
downloadhistorical-047fd1a1ed253626720059e77537c9cdbeebe496.tar.gz
historical-047fd1a1ed253626720059e77537c9cdbeebe496.tar.bz2
historical-047fd1a1ed253626720059e77537c9cdbeebe496.zip
Minor formatting and whitespace changes.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild')
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
index fa83c728020f..31c69bfe58af 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild,v 1.19 2007/05/30 13:32:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r10.ebuild,v 1.20 2007/06/01 06:09:49 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -132,12 +132,12 @@ src_compile() {
myconf="${myconf} --without-gtk"
elif use motif; then
einfo "Configuring to build with motif toolkit support"
- myconf="${myconf} --without-gtk"
myconf="${myconf} --with-x-toolkit=motif"
+ myconf="${myconf} --without-gtk"
else
einfo "Configuring to build with no toolkit"
- myconf="${myconf} --without-gtk"
myconf="${myconf} --with-x-toolkit=no"
+ myconf="${myconf} --without-gtk"
fi
else
myconf="${myconf} --without-x"
@@ -152,8 +152,7 @@ src_compile() {
--without-carbon \
${myconf} || die "econf emacs failed"
- emake CC="$(tc-getCC) " bootstrap \
- || die "make bootstrap failed."
+ emake CC="$(tc-getCC)" bootstrap || die "make bootstrap failed"
}
src_install () {
@@ -165,7 +164,7 @@ src_install () {
|| die "moving Emacs executable failed"
# move info documentation to the correct place
- einfo "Fixing info documentation..."
+ einfo "Fixing info documentation ..."
dodir /usr/share/info/emacs-${SLOT}
mv "${D}"/usr/share/info/{,emacs-${SLOT}/}dir || die "mv dir failed"
for i in "${D}"/usr/share/info/*
@@ -176,7 +175,7 @@ src_install () {
done
# move man pages to the correct place
- einfo "Fixing manpages..."
+ einfo "Fixing manpages ..."
for m in "${D}"/usr/share/man/man1/* ; do
mv ${m} ${m%.1}-emacs-${SLOT}.1 || die "mv man failed"
done
@@ -191,12 +190,12 @@ src_install () {
# This is not meant to install all the source -- just the
# C source you might find via find-function
doins src/*.[ch]
- sed 's/^X//' >00emacs-cvs-${SLOT}-gentoo.el <<EOF
+ sed 's/^X//' >00${PN}-${SLOT}-gentoo.el <<EOF
(if (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
X (setq find-function-C-source-directory
X "/usr/share/emacs/${FULL_VERSION}/src"))
EOF
- elisp-site-file-install 00emacs-cvs-${SLOT}-gentoo.el
+ elisp-site-file-install 00${PN}-${SLOT}-gentoo.el
fi
dodoc AUTHORS BUGS CONTRIBUTE README || die "dodoc failed"