summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2005-01-25 15:39:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2005-01-25 15:39:03 +0000
commit307b8c3a4d955343067f0f86d3a6c23fe293b08f (patch)
tree8de8b6f3a04948014de53829ef2e99c07170d085 /app-editors/leafpad/leafpad-0.7.9.ebuild
parentFix use of need-kde. (diff)
downloadhistorical-307b8c3a4d955343067f0f86d3a6c23fe293b08f.tar.gz
historical-307b8c3a4d955343067f0f86d3a6c23fe293b08f.tar.bz2
historical-307b8c3a4d955343067f0f86d3a6c23fe293b08f.zip
initial import
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'app-editors/leafpad/leafpad-0.7.9.ebuild')
-rw-r--r--app-editors/leafpad/leafpad-0.7.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/leafpad/leafpad-0.7.9.ebuild b/app-editors/leafpad/leafpad-0.7.9.ebuild
new file mode 100644
index 000000000000..80e56d8ce873
--- /dev/null
+++ b/app-editors/leafpad/leafpad-0.7.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leafpad/leafpad-0.7.9.ebuild,v 1.1 2005/01/25 15:39:03 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple gtk+ text editor"
+HOMEPAGE="http://tarot.freeshell.org/leafpad/"
+SRC_URI="http://savannah.nongnu.org/download/leafpad/${P}.tar.gz
+ mirror://gentoo/${P}-file_chooser.patch.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND=">=x11-libs/gtk+-2.4"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${P}-file_chooser.patch
+}
+
+src_compile() {
+ econf --disable-rpath `use_enable nls`
+ emake
+}
+
+src_install() {
+ einstall
+ dodoc AUTHORS ChangeLog COPYING NEWS README
+}