summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-22 07:53:27 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-22 07:53:27 +0000
commit565715f1db9b8140453340e99a799175ab6d0172 (patch)
treece9bdbe12a2db9fef5a1dca78ce98a0172701445 /app-editors/nano/nano-1.2.0.ebuild
parentadd arm patch to fix gcc from generating incorrect code (diff)
downloadhistorical-565715f1db9b8140453340e99a799175ab6d0172.tar.gz
historical-565715f1db9b8140453340e99a799175ab6d0172.tar.bz2
historical-565715f1db9b8140453340e99a799175ab6d0172.zip
version bump
Diffstat (limited to 'app-editors/nano/nano-1.2.0.ebuild')
-rw-r--r--app-editors/nano/nano-1.2.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/nano/nano-1.2.0.ebuild b/app-editors/nano/nano-1.2.0.ebuild
new file mode 100644
index 000000000000..a0e3b0fb9725
--- /dev/null
+++ b/app-editors/nano/nano-1.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.0.ebuild,v 1.1 2003/02/22 07:51:56 vapier Exp $
+
+MY_P="${PN}-${PV/_}"
+DESCRIPTION="clone of Pico with more functions in a smaller size"
+SRC_URI="http://www.nano-editor.org/dist/v1.2/${MY_P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+IUSE="nls build slang spell"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/editor"
+
+src_compile() {
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ `use_enable spell` \
+ `use_enable nls` \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ use build \
+ && rm -rf ${D}/usr/share \
+ || dodoc ChangeLog README nanorc.sample AUTHORS BUGS NEWS TODO \
+ && dohtml *.html
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}