summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-26 12:29:32 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-26 12:29:32 +0000
commit1ba3e1981276941da1fec7bb352912fa39e4ab5c (patch)
tree526a2353cc3a6710a5f5062225e629c08d9cf60e /app-editors/nano/nano-2.0.1.ebuild
parentAdd support for installing examples via USE=examples. (diff)
downloadhistorical-1ba3e1981276941da1fec7bb352912fa39e4ab5c.tar.gz
historical-1ba3e1981276941da1fec7bb352912fa39e4ab5c.tar.bz2
historical-1ba3e1981276941da1fec7bb352912fa39e4ab5c.zip
Version bump.
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'app-editors/nano/nano-2.0.1.ebuild')
-rw-r--r--app-editors/nano/nano-2.0.1.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/app-editors/nano/nano-2.0.1.ebuild b/app-editors/nano/nano-2.0.1.ebuild
new file mode 100644
index 000000000000..b1635c795f0c
--- /dev/null
+++ b/app-editors/nano/nano-2.0.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.1.ebuild,v 1.1 2006/11/26 12:29:32 vapier Exp $
+
+#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+#ECVS_MODULE="nano"
+#ECVS_AUTH="pserver"
+#ECVS_USER="anonymous"
+#inherit cvs
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+PROVIDE="virtual/editor"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ --disable-wrapping-as-root \
+ $(use_enable spell) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+
+ insinto /usr/share/nano
+ doins "${FILESDIR}"/*.nanorc || die
+ echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
+
+pkg_postinst() {
+ einfo "More helpful info about nano, visit the GDP page:"
+ einfo "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}