summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-03-23 20:36:26 +0000
committerAron Griffis <agriffis@gentoo.org>2003-03-23 20:36:26 +0000
commit4963d18da59bca3cb5d45f7b55531c36a6076add (patch)
treecb15cb81a1df21b849885662d17c2baf70a776fb /app-editors/vim-core
parentupdate vim eclass to patchlevel 411 (diff)
downloadhistorical-4963d18da59bca3cb5d45f7b55531c36a6076add.tar.gz
historical-4963d18da59bca3cb5d45f7b55531c36a6076add.tar.bz2
historical-4963d18da59bca3cb5d45f7b55531c36a6076add.zip
update vim eclass to patchlevel 411
Diffstat (limited to 'app-editors/vim-core')
-rw-r--r--app-editors/vim-core/ChangeLog9
-rw-r--r--app-editors/vim-core/files/digest-vim-core-6.1-r54
-rw-r--r--app-editors/vim-core/files/vimrc76
-rw-r--r--app-editors/vim-core/vim-core-6.1-r5.ebuild17
4 files changed, 105 insertions, 1 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 140f499cf60d..d13541b5670d 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.16 2003/03/15 00:44:40 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.17 2003/03/23 20:36:26 agriffis Exp $
+
+*vim-core-6.1-r5 (22 Mar 2003)
+
+ 22 Mar 2003; Aron Griffis <agriffis@gentoo.org> vim-core-6.1-r5.ebuild,
+ files/vimrc:
+ Move vimrc from vim to vim-core. Update to patchlevel 411. Mark stable on
+ x86, alpha. Changes to the eclass are described in the vim ChangeLog.
08 Feb 2003; Guy Martin <gmsoft@gentoo.org> vim-core-6.1-r4.ebuild :
Added hppa to keywords.
diff --git a/app-editors/vim-core/files/digest-vim-core-6.1-r5 b/app-editors/vim-core/files/digest-vim-core-6.1-r5
new file mode 100644
index 000000000000..98143868eb94
--- /dev/null
+++ b/app-editors/vim-core/files/digest-vim-core-6.1-r5
@@ -0,0 +1,4 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 289004
+MD5 ed6742805866d11d6a28267330980ab1 vim-6.1-lang.tar.gz 86697
+MD5 71932d38e43dad63d5d39de792d7ed4d vim-6.1-patches-001-411.tar.bz2 75693
+MD5 76999e6185b11a083061df23560e3a0c vim-6.1-411-gentoo-patches.tar.bz2 14480
diff --git a/app-editors/vim-core/files/vimrc b/app-editors/vim-core/files/vimrc
new file mode 100644
index 000000000000..c868e6d3c62a
--- /dev/null
+++ b/app-editors/vim-core/files/vimrc
@@ -0,0 +1,76 @@
+" Default configuration file for Vim
+" Written by Aron Griffis <agriffis@gentoo.org>
+" Modified by Ryan Phillips <rphillips@gentoo.org>
+" Added Redhat's vimrc info by Seemant Kulleen <seemant@gentoo.org>
+
+" The following are some sensible defaults for Vim for most users.
+" We attempt to change as little as possible from Vim's defaults,
+" deviating only where it makes sense
+set nocompatible " Use Vim defaults (much better!)
+set bs=2 " Allow backspacing over everything in insert mode
+set ai " Always set auto-indenting on
+"set backup " Keep a backup file
+set viminfo='20,\"50 " read/write a .viminfo file -- limit to only 50
+set history=50 " keep 50 lines of command history
+set ruler " Show the cursor position all the time
+
+" Added to default to high security within Gentoo. Fixes bug #14088
+set modelines=0
+
+if v:lang =~ "^ko"
+ set fileencodings=euc-kr
+ set guifontset=-*-*-medium-r-normal--16-*-*-*-*-*-*-*
+elseif v:lang =~ "^ja_JP"
+ set fileencodings=euc-jp
+ set guifontset=-misc-fixed-medium-r-normal--14-*-*-*-*-*-*-*
+elseif v:lang =~ "^zh_TW"
+ set fileencodings=big5
+ set guifontset=-sony-fixed-medium-r-normal--16-150-75-75-c-80-iso8859-1,-taipei-fixed-medium-r-normal--16-150-75-75-c-160-big5-0
+elseif v:lang =~ "^zh_CN"
+ set fileencodings=gb2312
+ set guifontset=*-r-*
+endif
+if v:lang =~ "utf8$" || v:lang =~ "UTF-8$"
+ set fileencodings=utf-8,latin1
+endif
+
+" Only do this part when compiled with support for autocommands
+if has("autocmd")
+ " In text files, always limit the width of text to 78 characters
+ autocmd BufRead *.txt set tw=78
+ " When editing a file, always jump to the last cursor position
+ autocmd BufReadPost *
+ \ if line("'\"") > 0 && line ("'\"") <= line("$") |
+ \ exe "normal g'\"" |
+ \ endif
+endif
+
+" Don't use Ex mode, use Q for formatting
+map Q gq
+
+" Switch syntax highlighting on, when the terminal has colors
+" Also switch on highlighting the last used search pattern.
+if &t_Co > 2 || has("gui_running")
+ syntax on
+ set hlsearch
+endif
+
+if &term=="xterm"
+ set t_RV= " don't check terminal version
+ set t_Co=8
+ set t_Sb=^[4%dm
+ set t_Sf=^[3%dm
+endif
+
+if has("autocmd")
+
+" Gentoo-specific settings for ebuilds. These are the federally-mandated
+" required tab settings. See the following for more information:
+" http://www.gentoo.org/doc/en/xml/gentoo-howto.xml
+augroup gentoo
+ au!
+ au BufRead,BufNewFile *.e{build,class} let is_bash=1|set ft=sh
+ au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab
+augroup END
+
+endif " has("autocmd")
diff --git a/app-editors/vim-core/vim-core-6.1-r5.ebuild b/app-editors/vim-core/vim-core-6.1-r5.ebuild
new file mode 100644
index 000000000000..0f400630a8b7
--- /dev/null
+++ b/app-editors/vim-core/vim-core-6.1-r5.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.1-r5.ebuild,v 1.1 2003/03/23 20:36:26 agriffis Exp $
+
+IUSE="gpm nls perl python ruby"
+VIMPATCH="411"
+inherit vim
+
+DESCRIPTION="vim, gvim and kvim shared files"
+KEYWORDS="x86 ~ppc ~sparc alpha ~hppa ~arm ~mips"
+DEPEND="dev-util/cscope
+ sys-libs/libtermcap-compat
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"