summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-04-01 15:34:15 +0000
committerUlrich Müller <ulm@gentoo.org>2012-04-01 15:34:15 +0000
commitc1f0843f73b89b0043420d1292c7d2e3e9be5d57 (patch)
treed91a347eda86df68dfe3328fbcb22066568c6f35 /app-editors/zile/zile-2.4.7.ebuild
parentsparc stable wrt #403019 (diff)
downloadhistorical-c1f0843f73b89b0043420d1292c7d2e3e9be5d57.tar.gz
historical-c1f0843f73b89b0043420d1292c7d2e3e9be5d57.tar.bz2
historical-c1f0843f73b89b0043420d1292c7d2e3e9be5d57.zip
Version bump. Remove intermediate version. Drop livecd USE flag.
Package-Manager: portage-2.1.10.53/cvs/Linux x86_64
Diffstat (limited to 'app-editors/zile/zile-2.4.7.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/zile/zile-2.4.7.ebuild b/app-editors/zile/zile-2.4.7.ebuild
new file mode 100644
index 000000000000..7647c3ace3a6
--- /dev/null
+++ b/app-editors/zile/zile-2.4.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zile/zile-2.4.7.ebuild,v 1.1 2012/04/01 15:34:15 ulm Exp $
+
+EAPI=4
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="http://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl test"
+
+RDEPEND="dev-libs/boehm-gc
+ sys-libs/ncurses
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-silent-rules \
+ $(use_enable acl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # AUTHORS, FAQ, and NEWS are installed by the build system
+ dodoc README THANKS
+
+ # Zile should never install charset.alias (even on non-glibc arches)
+ rm -f "${ED}"/usr/lib/charset.alias
+}