summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-21 10:37:45 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-21 10:37:45 +0000
commit51a38208181ec8b05486fa24294ddffc6b18fa5c (patch)
tree088bc2d327e18abb725c03e12a58f68c77158edb /app-editors
parentppc GRP profile vaccuuming (diff)
downloadhistorical-51a38208181ec8b05486fa24294ddffc6b18fa5c.tar.gz
historical-51a38208181ec8b05486fa24294ddffc6b18fa5c.tar.bz2
historical-51a38208181ec8b05486fa24294ddffc6b18fa5c.zip
Version bump. Removed sed stuff and changed install stanza. Added nls and spell USE variables.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/bluefish/ChangeLog8
-rw-r--r--app-editors/bluefish/Manifest6
-rw-r--r--app-editors/bluefish/bluefish-0.10.ebuild48
3 files changed, 59 insertions, 3 deletions
diff --git a/app-editors/bluefish/ChangeLog b/app-editors/bluefish/ChangeLog
index a2b018aeb1fd..c35e7ea25ba1 100644
--- a/app-editors/bluefish/ChangeLog
+++ b/app-editors/bluefish/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/bluefish
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.20 2003/05/22 18:20:21 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/ChangeLog,v 1.21 2003/07/21 10:37:44 raker Exp $
+
+*bluefish-0.10 (21 Jul 2003)
+
+ 21 Jul 2003; Nick Hadaway <raker@gentoo.org> bluefish-0.10.ebuild:
+ Got rid of the sed mess. Changed the install stanza accordingly.
+ Added nls and spell USE variables.
22 May 2003; Jason Wever <weeve@gentoo.org> bluefish-0.9.ebuild:
Changed ~sparc keyword to sparc.
diff --git a/app-editors/bluefish/Manifest b/app-editors/bluefish/Manifest
index dcead9aecdab..59e0e172b801 100644
--- a/app-editors/bluefish/Manifest
+++ b/app-editors/bluefish/Manifest
@@ -1,7 +1,9 @@
-MD5 148db97f62df9499b0605de27f42eec5 ChangeLog 2891
-MD5 745c86a5659c1d44a29523420cb99da4 bluefish-0.7-r3.ebuild 1139
MD5 5be71a473b05133ddbe7903f1a7a8dbc bluefish-0.8.ebuild 987
+MD5 fb6ab52f8881e432a9abc51f3a23c617 bluefish-0.10.ebuild 1323
MD5 655fc2d71c59fd78dbd1e2447679cffc bluefish-0.9.ebuild 1100
+MD5 64dd84b0a9915f595aa32cf1f4ce2bc1 ChangeLog 3096
+MD5 745c86a5659c1d44a29523420cb99da4 bluefish-0.7-r3.ebuild 1139
MD5 bd2f60953e3d3c182ef12e3f0a155ee2 files/digest-bluefish-0.7-r3 66
MD5 300af71b8263dedc97e775291b4e24b8 files/digest-bluefish-0.8 70
MD5 bc9b63ac2469bf96338ac088068828da files/digest-bluefish-0.9 65
+MD5 35e10591590d703d0c8571848ee228de files/digest-bluefish-0.10 66
diff --git a/app-editors/bluefish/bluefish-0.10.ebuild b/app-editors/bluefish/bluefish-0.10.ebuild
new file mode 100644
index 000000000000..e60787ceb664
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.10.ebuild,v 1.1 2003/07/21 10:37:45 raker Exp $
+
+IUSE="nls spell"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+
+DEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ dev-util/pkgconfig
+ spell? ( app-text/aspell )"
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ myconf=""
+ # --enable-auto-optimization let bluefish determine optimization
+ # --disable-splash-screen disables the splash screen
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+ dodir /usr/share/gnome/apps
+
+ einstall \
+ datadir=${D}/usr/share \
+ pkgdatadir=${D}/usr/share/bluefish \
+ pixmapsdir=${D}/usr/share/pixmaps \
+ iconpath=${D}/usr/share/pixmaps \
+ gnome2menupath=${D}/usr/share/applications \
+ gnome1menupath=${D}/usr/share/gnome/apps \
+ || die "make install failed"
+}