summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2007-02-03 11:25:24 +0000
committerChristian Faulhammer <fauli@gentoo.org>2007-02-03 11:25:24 +0000
commitf314d7fb3642aef8c122e77255475301e27ef5e9 (patch)
tree2834024454d350ae6b719a45017ae874811cdf17 /app-editors
parentInitial import, bug 125960. Slightly updated ebuild from Panard <panard.inzen... (diff)
downloadhistorical-f314d7fb3642aef8c122e77255475301e27ef5e9.tar.gz
historical-f314d7fb3642aef8c122e77255475301e27ef5e9.tar.bz2
historical-f314d7fb3642aef8c122e77255475301e27ef5e9.zip
determine compression suffix correctly and finally
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-cvs/ChangeLog6
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild7
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild7
-rw-r--r--app-editors/emacs/ChangeLog5
-rw-r--r--app-editors/emacs/emacs-21.4-r6.ebuild7
5 files changed, 24 insertions, 8 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index b6a6759fd64a..5f16a773d39a 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.77 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.78 2007/02/03 11:21:02 opfer Exp $
+
+ 03 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+ emacs-cvs-22.0.93-r2.ebuild, emacs-cvs-22.0.9999-r2.ebuild:
+ determine compression suffix correctly and finally
02 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
emacs-cvs-22.0.93-r2.ebuild, emacs-cvs-22.0.9999-r2.ebuild:
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
index 7888f73bf1e8..f1452dd5a83d 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild,v 1.3 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild,v 1.4 2007/02/03 11:21:02 opfer Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -167,6 +167,9 @@ EOF
}
update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -177,7 +180,7 @@ update-alternatives() {
for j in emacs emacsclient etags ctags
do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
done
}
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild
index 660ffd152db3..95ccbb49aaea 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild,v 1.3 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild,v 1.4 2007/02/03 11:21:02 opfer Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -172,6 +172,9 @@ EOF
}
update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -182,7 +185,7 @@ update-alternatives() {
for j in emacs emacsclient etags ctags
do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
done
}
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 179e97a5f8dc..a6daf0d1a04e 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.115 2007/02/02 20:14:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.116 2007/02/03 11:25:24 opfer Exp $
+
+ 03 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
+ determine compression suffix correctly and finally
02 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
hopefully fix man page symlinks again, part II
diff --git a/app-editors/emacs/emacs-21.4-r6.ebuild b/app-editors/emacs/emacs-21.4-r6.ebuild
index 4491936c1a16..804fd2529cbc 100644
--- a/app-editors/emacs/emacs-21.4-r6.ebuild
+++ b/app-editors/emacs/emacs-21.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.3 2007/02/02 20:14:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.4 2007/02/03 11:25:24 opfer Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -159,6 +159,9 @@ src_install() {
}
update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -168,7 +171,7 @@ update-alternatives() {
for j in emacs emacsclient etags ctags
do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
done
}