summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-04-20 15:30:57 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-04-20 15:30:57 +0000
commit5df4466b6aef240733e2421ff12554d5ae352967 (patch)
tree6f738d394020dcd276eb7967397c9b524daf2a70 /app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild
parentVersion bumped. Closes 41907 (diff)
downloadhistorical-5df4466b6aef240733e2421ff12554d5ae352967.tar.gz
historical-5df4466b6aef240733e2421ff12554d5ae352967.tar.bz2
historical-5df4466b6aef240733e2421ff12554d5ae352967.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild')
-rw-r--r--app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild b/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild
new file mode 100644
index 000000000000..c8dddd5f1d85
--- /dev/null
+++ b/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/aspectj4emacs/aspectj4emacs-1.1_beta2.ebuild,v 1.1 2004/04/20 15:30:57 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+MYPV="1.1b2"
+
+DESCRIPTION="AspectJ support for GNU Emacs java-mode and JDEE"
+HOMEPAGE="http://aspectj4emacs.sourceforge.net/"
+SRC_URI="http://aspectj4emacs.sourceforge.net/AspectJForEmacs-${MYPV}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ app-emacs/jde
+ =dev-java/aspectj-1.1*"
+
+S="${WORKDIR}/AspectJForEmacs-${MYPV}"
+
+SITEFILE=80aspectj4emacs-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PF}-compile-log-gentoo.patch
+ cd ${S}
+ cp */*.el .
+ sed -i "s,@build.version.short@,${PV},g" *.el
+}
+
+src_compile() {
+ elisp-comp *.el || die
+}
+
+src_install() {
+ elisp_src_install
+ for subdir in ajdee aspectj-mode; do
+ insinto /usr/share/doc/${PF}/${subdir}
+ doins `find ${subdir} -type f ! -name \*.el`
+ dosym /usr/share/doc/${PF}/html/${subdir}.html \
+ /usr/share/emacs/site-lisp/${PN}/${subdir}.html
+ done
+ dohtml *.html *.gif
+}