summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2003-12-29 00:44:33 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2003-12-29 00:44:33 +0000
commitf27731f14326cca39f2ade88d27c64181b7dd203 (patch)
tree92a47e203ef7cddf693525b2105f156866d0f07e /app-emacs/lua-mode/lua-mode-1.26-r1.ebuild
parentRevision bump: fixed src_compile() (diff)
downloadhistorical-f27731f14326cca39f2ade88d27c64181b7dd203.tar.gz
historical-f27731f14326cca39f2ade88d27c64181b7dd203.tar.bz2
historical-f27731f14326cca39f2ade88d27c64181b7dd203.zip
Revision bump: fixed src_compile()
Diffstat (limited to 'app-emacs/lua-mode/lua-mode-1.26-r1.ebuild')
-rw-r--r--app-emacs/lua-mode/lua-mode-1.26-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-emacs/lua-mode/lua-mode-1.26-r1.ebuild b/app-emacs/lua-mode/lua-mode-1.26-r1.ebuild
new file mode 100644
index 000000000000..dcd395587af6
--- /dev/null
+++ b/app-emacs/lua-mode/lua-mode-1.26-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/lua-mode/lua-mode-1.26-r1.ebuild,v 1.1 2003/12/29 00:44:20 jbms Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing Lua scripts"
+HOMEPAGE="http://lua-users.org/wiki/LuaEditorSupport"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+SITEFILE="70${PN}-gentoo.el"
+
+src_compile() {
+ /usr/bin/emacs -batch --no-site-file --no-init-file \
+ --load "${S}/lua-mode.el" -f batch-byte-compile lua-mode.el
+}