summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commitce2fa6f6c4951c11ef10627b81603f112c0b62a8 (patch)
tree3f697c6e444c56ff856d2d5e5300c606d2462d12 /app-emacs/monk
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadhistorical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.gz
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.tar.bz2
historical-ce2fa6f6c4951c11ef10627b81603f112c0b62a8.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/monk')
-rw-r--r--app-emacs/monk/ChangeLog11
-rw-r--r--app-emacs/monk/files/50monk-gentoo.el60
-rw-r--r--app-emacs/monk/files/digest-monk-7.440
-rw-r--r--app-emacs/monk/monk-7.44.ebuild37
4 files changed, 108 insertions, 0 deletions
diff --git a/app-emacs/monk/ChangeLog b/app-emacs/monk/ChangeLog
new file mode 100644
index 000000000000..514ea6f2d860
--- /dev/null
+++ b/app-emacs/monk/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/monk
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/monk/ChangeLog,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+*monk-7.44 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ monk-7.44.ebuild, files/50monk-gentoo.el,
+ files/digest-monk-7.44 :
+
+ Initial import.
diff --git a/app-emacs/monk/files/50monk-gentoo.el b/app-emacs/monk/files/50monk-gentoo.el
new file mode 100644
index 000000000000..fcd5e2a26f39
--- /dev/null
+++ b/app-emacs/monk/files/50monk-gentoo.el
@@ -0,0 +1,60 @@
+
+;;; monk site-lisp configuration
+
+(autoload 'monk "monk" nil t)
+
+(autoload 'monk-open-new "monk" nil t)
+(autoload 'monk-other-window "monk" nil t)
+(autoload 'monk-other-frame "monk" nil t)
+
+;; If you need volume control
+(setq monk-volume-command "aumix")
+
+;; Mouse bindings some more (to HipHop on the mode-line)
+(add-hook 'monk-load-hook 'monk-use-extra-mouse)
+
+;; Enable M-m (monk-dired-do-monk), and
+;; M-C-m (monk-dired-do-monk-find-file) in dired
+;; See also "Howto use monk-dired keyboard commands" section
+;; in monk.el.
+(autoload 'monk-dired-bind-extra-keys "monk" nil t)
+(add-hook 'dired-load-hook 'monk-dired-bind-extra-keys)
+;; dired *must* be loaded *after* this.
+
+;; I prefer this for M-m (monk-dired-do-monk) command in `dired'
+(setq monk-dired-monk-command 'monk-other-window)
+
+;; If you want to use remote cddb server to display track titles
+;; when cdda2wav can't generate the track/album titles.
+;; See monk-cddb script for detail.
+(setq monk-use-cddb-server t)
+
+;; To check CD media is in the drive (requires cdparanoia(1))
+(setq monk-dont-care-no-CD nil)
+
+;; In order to make the track timer work for MIDI track
+(setq monk-midi-probe-command "timidity")
+
+;; If menu-bar entry is required from the start
+ (let ((fmenu (or (lookup-key global-map [menu-bar tools])
+ (lookup-key global-map [menu-bar file]))))
+ (define-key-after fmenu [monk]
+ ;; '("MonK" . monk) ;; This is the same setup in monk.el
+ '("MonK" . monk-open-new) ;; monks may like this
+ 'calendar)
+ (x-popup-menu nil fmenu))
+
+;; Use `face' display for current playing track
+(setq monk-use-face t)
+;; Some examples of faces on emacs running as X client
+;; (All of these may not available on your emacs):
+;;
+;; ;; (setq monk-current-track-X-face-prop 'RoyalBlue)
+;; (progn
+;; (load "cus-edit")
+;; ;; (setq monk-current-track-X-face-prop 'custom-invalid-face)
+;; (setq monk-current-track-X-face-prop 'custom-set-face)
+;; )
+
+
+
diff --git a/app-emacs/monk/files/digest-monk-7.44 b/app-emacs/monk/files/digest-monk-7.44
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emacs/monk/files/digest-monk-7.44
diff --git a/app-emacs/monk/monk-7.44.ebuild b/app-emacs/monk/monk-7.44.ebuild
new file mode 100644
index 000000000000..d65cfc33e9bf
--- /dev/null
+++ b/app-emacs/monk/monk-7.44.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/monk/monk-7.44.ebuild,v 1.1 2002/11/01 02:52:01 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Multimedia Object Navigator Kluge (or whatever) for Emacs"
+HOMEPAGE="ftp://ftp.cis.ohio-state.edu/pub/emacs-lisp/archive/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50monk-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}