summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-09-22 13:09:21 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-09-22 13:09:21 +0000
commitd572e83c5f0e8302ec56712168c4d0765d12f940 (patch)
treea937d278a1c49ac76c42f41a48942accafef6eb1 /app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild
parentChange herd from commonbox to desktop-wm. (diff)
downloadhistorical-d572e83c5f0e8302ec56712168c4d0765d12f940.tar.gz
historical-d572e83c5f0e8302ec56712168c4d0765d12f940.tar.bz2
historical-d572e83c5f0e8302ec56712168c4d0765d12f940.zip
Add a package to quickly add support for DocBook 5 to nxml (whether standalone or included in emacs).
Package-Manager: portage-2.2_rc9/cvs/Linux 2.6.26-gentoo-r1 x86_64
Diffstat (limited to 'app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild')
-rw-r--r--app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild b/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild
new file mode 100644
index 000000000000..90dc14cb3831
--- /dev/null
+++ b/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/nxml-docbook5-schemas/nxml-docbook5-schemas-20080922.ebuild,v 1.1 2008/09/22 13:09:20 flameeyes Exp $
+
+inherit elisp
+
+DESCRIPTION="Add support for DocBook 5 schemas to NXML"
+HOMEPAGE="http://www.docbook.org/schemas/5x.html"
+SRC_URI="http://www.docbook.org/xml/5.0/rng/docbookxi.rnc"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( >=app-emacs/nxml-mode-20041004-r3 >=virtual/emacs-23 )"
+
+SITEFILE=60${PN}-gentoo.el
+
+src_compile() { :; }
+
+src_install() {
+ insinto ${SITEETC}/${PN}
+ doins "${FILESDIR}"/schemas.xml "${DISTDIR}"/docbookxi.rnc || die "install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+}
+
+pkg_postinst () {
+ elisp-site-regen
+
+ if [ $(emacs -batch -q --eval "(princ (fboundp 'nxml-mode))") = nil ]; then
+ ewarn "This package needs nxml-mode. You should either install"
+ ewarn "app-emacs/nxml-mode, or use \"eselect emacs\" to select"
+ ewarn "an Emacs version >= 23."
+ fi
+}