summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-20 18:06:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-20 18:06:46 +0000
commit35a2d0e84b8c350789c18d00dfef57b2ed02b4fa (patch)
tree03b922ac68a7e58af327a58f620d0001165ef2f1 /app-emacs/planner/planner-3.30.ebuild
parentVersion bump. (diff)
downloadhistorical-35a2d0e84b8c350789c18d00dfef57b2ed02b4fa.tar.gz
historical-35a2d0e84b8c350789c18d00dfef57b2ed02b4fa.tar.bz2
historical-35a2d0e84b8c350789c18d00dfef57b2ed02b4fa.zip
New upstream version.
Package-Manager: portage-2.0.53
Diffstat (limited to 'app-emacs/planner/planner-3.30.ebuild')
-rw-r--r--app-emacs/planner/planner-3.30.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/planner/planner-3.30.ebuild b/app-emacs/planner/planner-3.30.ebuild
new file mode 100644
index 000000000000..74adde3cd56d
--- /dev/null
+++ b/app-emacs/planner/planner-3.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/planner/planner-3.30.ebuild,v 1.1 2005/12/20 18:06:46 mkennedy Exp $
+
+inherit elisp
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="http://www.emacswiki.org/cgi-bin/wiki/PlannerMode"
+
+# Upstream sources are not reliably available, so we use the Debian
+# project's source archives
+
+SRC_URI="http://ftp.debian.org/debian/pool/main/p/planner-el/planner-el_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="app-emacs/emacs-wiki
+ sys-apps/texinfo"
+
+SITEFILE=80planner-gentoo.el
+
+S=${WORKDIR}/planner-el-${PV}
+
+src_compile() {
+ elisp-compile *.el
+ makeinfo planner-el.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ dodoc ChangeLog PLANNER-README
+ doinfo planner-el.info*
+}