summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-06-02 14:24:57 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-06-02 14:24:57 +0000
commit55442b45dacbdb99c8e1b874b94fb2a7e8d916ee (patch)
treeac705415661912f3abee3c961d01c6dfb157017b /app-emulation/bochs/bochs-2.2.6.ebuild
parentVersion bump. (diff)
downloadhistorical-55442b45dacbdb99c8e1b874b94fb2a7e8d916ee.tar.gz
historical-55442b45dacbdb99c8e1b874b94fb2a7e8d916ee.tar.bz2
historical-55442b45dacbdb99c8e1b874b94fb2a7e8d916ee.zip
New version, bug #130890
Package-Manager: portage-2.1_rc3-r5
Diffstat (limited to 'app-emulation/bochs/bochs-2.2.6.ebuild')
-rw-r--r--app-emulation/bochs/bochs-2.2.6.ebuild107
1 files changed, 107 insertions, 0 deletions
diff --git a/app-emulation/bochs/bochs-2.2.6.ebuild b/app-emulation/bochs/bochs-2.2.6.ebuild
new file mode 100644
index 000000000000..695a48e0f322
--- /dev/null
+++ b/app-emulation/bochs/bochs-2.2.6.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.2.6.ebuild,v 1.1 2006/06/02 14:24:57 lu_zero Exp $
+
+inherit eutils wxwidgets
+
+DESCRIPTION="a LGPL-ed pc emulator"
+HOMEPAGE="http://bochs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux4.tar.gz
+ mirror://gentoo/${P}-unicode.patch.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="debugger readline sdl wxwindows X ncurses vnc"
+
+RDEPEND="virtual/libc
+ X? ( || ( virtual/x11
+ ( x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm ) ) )
+ sdl? ( media-libs/libsdl )
+ wxwindows? ( >=x11-libs/wxGTK-2.6 )
+ readline? ( sys-libs/readline )
+ ncurses? ( sys-libs/ncurses )"
+
+DEPEND="${RDEPEND}
+ X? ( || ( virtual/x11
+ x11-proto/xproto ) )
+ >=sys-apps/sed-4
+ >=app-text/opensp-1.5"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ sed -i \
+ -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux4.tar.gz .:" \
+ -e "s:BOCHSDIR=:BOCHSDIR=/usr/$(get_libdir)/bochs#:" \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in || \
+ die "sed Makefile.in failed"
+
+# Make it use the correct path to gtk-2
+ sed -i -e "s:/opt/gnome:/usr:" configure
+# Fix some bad coding for gcc-4.1 compliance
+ sed -i -e "s:\#ifndef PARANOID:\#if 0:" iodev/hdimage.h
+# Make sure wxwindows 2.6 is used in case both 2.6 and 2.4 are installed
+ sed -i -e "s:wx-config:wx-config-2.6:" configure
+# wx unicode patches from fedora and bits the fedora missed
+ epatch ${DISTDIR}/${P}-unicode.patch.gz
+}
+
+src_compile() {
+ export WX_GTK_VER=2.6
+
+ use wxwindows && \
+ need-wxwidgets gtk2
+
+ [[ "$ARCH" == "x86" ]] \
+ && myconf="--enable-idle-hack --enable-fast-function-calls"
+ myconf="${myconf} `use_with sdl`"
+ myconf="${myconf} `use_enable readline`"
+ use wxwindows && \
+ myconf="${myconf} --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-wx"
+ use debugger && \
+ myconf="$myconf --enable-debugger --enable-disasm \
+ --enable-x86-debugger --enable-iodebug \
+ --enable-gdb-stub"
+ use vnc && \
+ myconf="$myconf --with-rfb"
+
+ use X && \
+ myconf="$myconf --with-x11"
+
+ use ncurses && \
+ myconf="$myconf --with-term"
+
+ if ! use X && ! use ncurses && ! use vnc && ! use sdl
+ then
+ myconf="$myconf --with-nogui"
+ fi
+
+# needed to use gtk2 includes and libs
+ autoconf
+ ./configure \
+ --enable-usb --enable-pci --enable-vbe \
+ --enable-sse=2 --enable-3dnow --enable-plugins \
+ --enable-cpu-level=6 --enable-all-optimizations \
+ --enable-ne2000 --enable-sb16=linux --enable-clgd54xx \
+ --enable-smp --enable-apic --enable-compressed-hd \
+ --enable-pni --enable-sep --host=${CHOST} \
+ --libdir=/usr/$(get_libdir) --prefix=/usr \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install unpack_dlx || die "make install failed"
+ #workaround
+ make prefix=${D}/usr install_dlx
+
+ dodoc CHANGES README TESTFORM.txt || die "dodoc failed"
+}