summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
commit374b06953c1041eff535d1da3ac9d2e921382b98 (patch)
tree5eedba8c721b40f0363f342915e3ad78ec7ffbf2 /app-emulation/psemu-peopsspu
parentdependency fix (diff)
downloadhistorical-374b06953c1041eff535d1da3ac9d2e921382b98.tar.gz
historical-374b06953c1041eff535d1da3ac9d2e921382b98.tar.bz2
historical-374b06953c1041eff535d1da3ac9d2e921382b98.zip
New package. Fixes #3266-#3274
Diffstat (limited to 'app-emulation/psemu-peopsspu')
-rw-r--r--app-emulation/psemu-peopsspu/ChangeLog13
-rw-r--r--app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.11
-rw-r--r--app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/psemu-peopsspu/ChangeLog b/app-emulation/psemu-peopsspu/ChangeLog
new file mode 100644
index 000000000000..8a45644e20a5
--- /dev/null
+++ b/app-emulation/psemu-peopsspu/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-peopsspu
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-peopsspu/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-peopsspu (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.1 b/app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.1
new file mode 100644
index 000000000000..93b2ce38955b
--- /dev/null
+++ b/app-emulation/psemu-peopsspu/files/digest-psemu-peopsspu-1.0.1
@@ -0,0 +1 @@
+MD5 3c0a29029eb42dd567c95978ffe35ae5 PeopsSpu101.zip 216281
diff --git a/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild b/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild
new file mode 100644
index 000000000000..ea9a06dc45bd
--- /dev/null
+++ b/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-peopsspu/psemu-peopsspu-1.0.1.ebuild,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+DESCRIPTION="P.E.Op.S Sound Emulation (SPU) PSEmu Plugin"
+HOMEPAGE="http://peops.sourceforge.net"
+LICENSE="GPL-2"
+DEPEND="app-arch/unzip
+ app-misc/fixdos
+ x11-libs/gtk+
+ sys-devel/automake"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/peops/PeopsSpu101.zip"
+S=${WORKDIR}/spuPeopsSound
+
+src_unpack() {
+ unzip -a ${DISTDIR}/PeopsSpu101.zip
+}
+
+src_compile() {
+ cd Src
+ mv StdAfx.c stdafx.c
+ mv StdAfx.h stdafx.h
+ mv OSS.H oss.h
+ emake CCFLAGS3="${CFLAGS} -fPIC -c -Wall -ffast-math -fomit-frame-pointer" || die
+ cd linuxcfg
+ tar xvfz spucfg.tar.gz
+ crlf . # convert all files in dir from dos CRLF to unix CR format...
+ automake --add-missing
+ ./configure
+ emake || die
+ mv src/spucfg src/cfgPeopsOSS
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins
+ doins Src/libspu*
+ chmod 755 ${D}/usr/lib/psemu/plugins/*
+ insinto /usr/lib/psemu/cfg
+ doins Src/linuxcfg/src/cfgPeopsOSS
+ chmod 755 ${D}/usr/lib/psemu/cfg/*
+ dodoc Src/License.txt Src/changelog.txt
+ dodoc readme_1_1.txt version_1_1.txt
+}
+