summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-04 06:21:53 +0000
committerTod Neidt <tod@gentoo.org>2002-02-04 06:21:53 +0000
commit561fdbc6b4fcba2c89aa0d8ac5a15f0eb675614b (patch)
treea206901bd68948d595ae9b688847ed9f4fdbcbb9 /app-emulation/xmame
parentdigest-o-rama (diff)
downloadhistorical-561fdbc6b4fcba2c89aa0d8ac5a15f0eb675614b.tar.gz
historical-561fdbc6b4fcba2c89aa0d8ac5a15f0eb675614b.tar.bz2
historical-561fdbc6b4fcba2c89aa0d8ac5a15f0eb675614b.zip
Moved xmame to app-emulation with other emulators (Bug 421)
Old location in app-games package masked. Note: Additional game packages for xmame should still go in app-games
Diffstat (limited to 'app-emulation/xmame')
-rw-r--r--app-emulation/xmame/ChangeLog25
-rw-r--r--app-emulation/xmame/files/digest-xmame-0.55.21
-rw-r--r--app-emulation/xmame/files/digest-xmame-0.56.11
-rw-r--r--app-emulation/xmame/xmame-0.55.2.ebuild57
-rw-r--r--app-emulation/xmame/xmame-0.56.1.ebuild57
5 files changed, 141 insertions, 0 deletions
diff --git a/app-emulation/xmame/ChangeLog b/app-emulation/xmame/ChangeLog
new file mode 100644
index 000000000000..fe497b303030
--- /dev/null
+++ b/app-emulation/xmame/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for app-games/xmame
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/ChangeLog,v 1.1 2002/02/04 06:21:53 tod Exp $
+
+*xmame-0.56.1 ((3 Feb 2002)
+
+ 3 Feb 2002; T.Neidt <tneidt@gentoo.org> ChangeLog :
+
+ Moved to app-emulation/xmame with the other emulators (Bug 421)
+
+*xmame-0.55.2 ((3 Feb 2002)
+
+ 3 Feb 2002; T.Neidt <tneidt@gentoo.org> ChangeLog :
+
+ Moved to app-emulation/xmame with the other emulators (Bug 421)
+
+*xmame-0.56.1 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/xmame/files/digest-xmame-0.55.2 b/app-emulation/xmame/files/digest-xmame-0.55.2
new file mode 100644
index 000000000000..17092f291ef1
--- /dev/null
+++ b/app-emulation/xmame/files/digest-xmame-0.55.2
@@ -0,0 +1 @@
+MD5 23ebdb97a56690678b881f883089675a xmame-0.55.2.tar.bz2 5176861
diff --git a/app-emulation/xmame/files/digest-xmame-0.56.1 b/app-emulation/xmame/files/digest-xmame-0.56.1
new file mode 100644
index 000000000000..da0ca283d36f
--- /dev/null
+++ b/app-emulation/xmame/files/digest-xmame-0.56.1
@@ -0,0 +1 @@
+MD5 220c071b2852b883b98cb8f637df17c4 xmame-0.56.1.tar.bz2 5263162
diff --git a/app-emulation/xmame/xmame-0.55.2.ebuild b/app-emulation/xmame/xmame-0.55.2.ebuild
new file mode 100644
index 000000000000..40b39dceafae
--- /dev/null
+++ b/app-emulation/xmame/xmame-0.55.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <blutgens@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.55.2.ebuild,v 1.1 2002/02/04 06:21:53 tod Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+SRC_URI="http://x.mame.net/download/${P}.tar.bz2"
+HOMEPAGE="http://x.mame.net"
+
+DEPEND="virtual/x11
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ >=sys-libs/zlib-1.1.3-r2"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:CFLAGS = -O -Wall:\#CFLAGS=:g" -e \
+ "s:PREFIX = /usr/local:PREFIX = /usr:g" -e \
+ "s:MANDIR = \$\(PREFIX\)/man/man6:MANDIR = \$\(PREFIX\)/share/man/man6:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+
+ if [ "`use sdl`" ]; then
+ sed -e "s:DISPLAY_METHOD = x11:DISPLAY_METHOD = SDL:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+ fi
+
+ if [ "`use esd`" ]; then
+ sed -e "s/\# SOUND_ESOUND/SOUND_ESOUND/g" makefile.unix > Makefile
+ else
+ mv makefile.unix Makefile
+ fi
+}
+
+src_compile() {
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+
+ make PREFIX=${D}/usr install
+
+# dodoc gzips
+ dodoc doc/{changes.*,changes.unix,gamelist.mame,readme.mame,xmamerc.dist}
+ dodoc doc/{xmame-doc.ps,xmame-doc.txt}
+# Don't really want html files gzipped
+ insinto /usr/share/doc/${P}/html
+ doins doc/*.html
+
+ dosym xmame.SDL /usr/bin/xmame
+
+}
+
diff --git a/app-emulation/xmame/xmame-0.56.1.ebuild b/app-emulation/xmame/xmame-0.56.1.ebuild
new file mode 100644
index 000000000000..460441beba28
--- /dev/null
+++ b/app-emulation/xmame/xmame-0.56.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <blutgens@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xmame/xmame-0.56.1.ebuild,v 1.1 2002/02/04 06:21:53 tod Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Multiple Arcade Machine Emulator for X11"
+SRC_URI="http://x.mame.net/download/${P}.tar.bz2"
+HOMEPAGE="http://x.mame.net"
+
+DEPEND="virtual/x11
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ >=sys-libs/zlib-1.1.3-r2"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:CFLAGS = -O -Wall:\#CFLAGS=:g" -e \
+ "s:PREFIX = /usr/local:PREFIX = /usr:g" -e \
+ "s:MANDIR = \$\(PREFIX\)/man/man6:MANDIR = \$\(PREFIX\)/share/man/man6:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+
+ if [ "`use sdl`" ]; then
+ sed -e "s:DISPLAY_METHOD = x11:DISPLAY_METHOD = SDL:g" \
+ makefile.unix > makefile.unix.tmp
+ mv makefile.unix.tmp makefile.unix
+ fi
+
+ if [ "`use esd`" ]; then
+ sed -e "s/\# SOUND_ESOUND/SOUND_ESOUND/g" makefile.unix > Makefile
+ else
+ mv makefile.unix Makefile
+ fi
+}
+
+src_compile() {
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+
+ make PREFIX=${D}/usr install
+
+# dodoc gzips
+ dodoc doc/{changes.*,dga2.txt,gamelist.mame,readme.mame,xmamerc.dist}
+ dodoc doc/{xmame-doc.ps,xmame-doc.txt}
+# Don't really want html files gzipped
+ insinto /usr/share/doc/${P}/html
+ doins doc/*.html
+
+ dosym xmame.SDL /usr/bin/xmame
+
+}
+