summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-03-21 14:22:40 +0000
committerDavid Holm <dholm@gentoo.org>2004-03-21 14:22:40 +0000
commit0a0f9da619cbcd16d0b25bafbed203ab4c5a5d38 (patch)
treeea52d5510c077b2f28a73597374036e4cd9629c5 /app-emulation
parentQA: Unnecessary definition of S removed. Adding categories to dependencies. S... (diff)
downloadhistorical-0a0f9da619cbcd16d0b25bafbed203ab4c5a5d38.tar.gz
historical-0a0f9da619cbcd16d0b25bafbed203ab4c5a5d38.tar.bz2
historical-0a0f9da619cbcd16d0b25bafbed203ab4c5a5d38.zip
Moved basiliskII-jit to it's own directory. Added latest basiliskII prerelease and unmasked on ~ppc. Added metadata.xml
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/basiliskII/ChangeLog12
-rw-r--r--app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild (renamed from app-emulation/basiliskII/basiliskII-1.0.0.ebuild)49
-rw-r--r--app-emulation/basiliskII/files/digest-basiliskII-1.0.01
-rw-r--r--app-emulation/basiliskII/files/digest-basiliskII-1.0.0_pre200201151
-rw-r--r--app-emulation/basiliskII/metadata.xml6
5 files changed, 38 insertions, 31 deletions
diff --git a/app-emulation/basiliskII/ChangeLog b/app-emulation/basiliskII/ChangeLog
index f8eb9d5b9e6c..9d69ceacd493 100644
--- a/app-emulation/basiliskII/ChangeLog
+++ b/app-emulation/basiliskII/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/basiliskII
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/ChangeLog,v 1.9 2003/12/08 19:03:09 mr_bones_ Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/ChangeLog,v 1.10 2004/03/21 14:22:39 dholm Exp $
+
+*basiliskII-1.0.0_pre20020115 (21 Mar 2004)
+
+ 21 Mar 2004; David Holm <dholm@gentoo.org> basiliskII-1.0.0.ebuild,
+ basiliskII-1.0.0_pre20020115.ebuild, metadata.xml:
+ Moved basiliskII-1.0.0.ebuild to basiliskII-jit since it is a fork of
+ basiliskII and not the same project. Added the latest prerelease of basiliskII
+ and added ~ppc to the keywords.
08 Dec 2003; Michael Sterrett <mr_bones_@gentoo.org>
basiliskII-1.0.0.ebuild:
diff --git a/app-emulation/basiliskII/basiliskII-1.0.0.ebuild b/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
index 86e774b622a3..166b0ae1b37e 100644
--- a/app-emulation/basiliskII/basiliskII-1.0.0.ebuild
+++ b/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0.ebuild,v 1.4 2004/02/20 06:03:52 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/basiliskII/basiliskII-1.0.0_pre20020115.ebuild,v 1.1 2004/03/21 14:22:40 dholm Exp $
+
+IUSE="X gtk xv esd dga"
inherit flag-o-matic
@@ -8,38 +10,32 @@ inherit flag-o-matic
### Mac OS 7.5.3r2 is available freely from the Apple Homepage
### System ROMS can be retreived from a 'real' Mac, See info/man pages
-S="${WORKDIR}/BasiliskII-jit-1.0/src/Unix"
-DESCRIPTION="BasiliskII Macintosh Emulator"
-HOMEPAGE="http://gwenole.beauchesne.online.fr/basilisk2/"
-SRC_URI="http://hometown.aol.de/wimdk/files/BasiliskII-jit-1.0-mdk-src.tar.bz2"
-
+DESCRIPTION="BasiliskII-0.9.0 Macintosh Emulator (Stable Release)"
+HOMEPAGE="http://www.uni-mainz.de/~bauec002/B2Main.html"
LICENSE="GPL-2 | LGPL-2.1"
-KEYWORDS="x86 -ppc"
+KEYWORDS="~x86 ~ppc"
SLOT="0"
-IUSE="X gtk xv esd dga"
+### We'll set $S Manually, it's version dependant, and nested strangely.
+S=${WORKDIR}/BasiliskII-1.0/src/Unix
### fbdev support in the stable release... the cvs branch is broken, period!
### gtk and esd support are compile time options, we'll check the usual
### use variables here and set ./configure options accordingly
DEPEND="gtk? ( x11-libs/gtk+ )
- esd? ( media-sound/esound )
- >=sys-apps/sed-4"
+ esd? ( media-sound/esound )"
-src_unpack() {
- unpack ${A}
- # Fix up the vendor (bug 35352)
- sed -i \
- -e "s/Mandrake/Gentoo/g" ${S}/keycodes || \
- die "sed keycods failed"
-}
+SRC_URI="http://iphcip1.physik.uni-mainz.de/~cbauer/BasiliskII_src_15012002.tar.gz"
src_compile() {
+
#fpu_x86 doesnt compile properly if -O3 or greater :(
replace-flags -O[3-9] -O2
+ strip-flags -mpowerpc-gfxopt
+
local myflags
### Default ./configure options are all =yes by default. we'll check for
@@ -56,26 +52,22 @@ src_compile() {
--prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
- --enable-jit-compiler \
- ${myflags} || die "./configure failed"
+ ${myflags} || die "BasiliskII ./configure Failed"
#hack to link against libstdc++ for gcc3.x compatibility
- sed -i \
- -e 's:-o $(OBJ_DIR)/gencpu:-lstdc++ -o $(OBJ_DIR)/gencpu:' \
- Makefile || die "sed Makefile failed"
+ cp Makefile Makefile.old
+ sed -e 's:-o $(OBJ_DIR)/gencpu:-lstdc++ -o $(OBJ_DIR)/gencpu:' \
+ Makefile.old > Makefile
- emake || die "emake failed"
+ emake || die "BasiliskII Make Failed"
}
-src_install() {
+src_install () {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
- install || die "make install failed"
-
- cd ../..
- dodoc ChangeLog INSTALL README TECH TODO TODO.JIT
+ install || die "BasiliskII Make Install Failed"
### Networking is _disabled_ in this revision, hopefully -r2 will
### resolve the permissions issue / linux src compilation problem
@@ -86,4 +78,5 @@ src_install() {
### provides (effectivly) an ethernet bridge between basliskII and the kernel
# make modules
+
}
diff --git a/app-emulation/basiliskII/files/digest-basiliskII-1.0.0 b/app-emulation/basiliskII/files/digest-basiliskII-1.0.0
deleted file mode 100644
index 3679057027e2..000000000000
--- a/app-emulation/basiliskII/files/digest-basiliskII-1.0.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 de61127f222213d066ac8317cb87e625 BasiliskII-jit-1.0-mdk-src.tar.bz2 597741
diff --git a/app-emulation/basiliskII/files/digest-basiliskII-1.0.0_pre20020115 b/app-emulation/basiliskII/files/digest-basiliskII-1.0.0_pre20020115
new file mode 100644
index 000000000000..098190845945
--- /dev/null
+++ b/app-emulation/basiliskII/files/digest-basiliskII-1.0.0_pre20020115
@@ -0,0 +1 @@
+MD5 6d8a128a3dd1f6800d6b0275f1ad8db0 BasiliskII_src_15012002.tar.gz 494773
diff --git a/app-emulation/basiliskII/metadata.xml b/app-emulation/basiliskII/metadata.xml
new file mode 100644
index 000000000000..e4c9545bcc25
--- /dev/null
+++ b/app-emulation/basiliskII/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<longdescription>Basilisk II is an Open Source 68k Macintosh emulator. That is, it enables you to run 68k MacOS software on you computer, even if you are using a different operating system. However, you still need a copy of MacOS and a Macintosh ROM image to use Basilisk II.</longdescription>
+</pkgmetadata>