summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-21 16:23:06 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-21 16:23:06 +0000
commit900f7cdb338bfd15298d1fa981bad7ad53b916e3 (patch)
tree3a453d9774b7c8d9ff174aada3b72c78b20c8afb /app-emulation
parentmove wc to /bin (diff)
downloadhistorical-900f7cdb338bfd15298d1fa981bad7ad53b916e3.tar.gz
historical-900f7cdb338bfd15298d1fa981bad7ad53b916e3.tar.bz2
historical-900f7cdb338bfd15298d1fa981bad7ad53b916e3.zip
new version
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/zsnes/ChangeLog9
-rw-r--r--app-emulation/zsnes/files/digest-zsnes-1.361
-rw-r--r--app-emulation/zsnes/zsnes-1.36.ebuild36
3 files changed, 45 insertions, 1 deletions
diff --git a/app-emulation/zsnes/ChangeLog b/app-emulation/zsnes/ChangeLog
index 0ac45af86697..4b6c3c941edb 100644
--- a/app-emulation/zsnes/ChangeLog
+++ b/app-emulation/zsnes/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/zsnes
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.8 2002/07/21 00:55:49 sunflare Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.9 2002/07/21 16:23:06 danarmak Exp $
+
+*zsnes-1.26 (21 Jul 2002)
+
+ 21 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New upstream version.
+
20 Jul 2002; Phil Bordelon <sunflare@gentoo.org> zsnes-1.35.ebuild zsnes-1.35-r1.ebuild zsnes-1.337-r2.ebuild :
diff --git a/app-emulation/zsnes/files/digest-zsnes-1.36 b/app-emulation/zsnes/files/digest-zsnes-1.36
new file mode 100644
index 000000000000..95b924b5ba5a
--- /dev/null
+++ b/app-emulation/zsnes/files/digest-zsnes-1.36
@@ -0,0 +1 @@
+MD5 576f6f5cc50c7c6f7877aca220ee99b3 zsnes136src.tar.gz 901081
diff --git a/app-emulation/zsnes/zsnes-1.36.ebuild b/app-emulation/zsnes/zsnes-1.36.ebuild
new file mode 100644
index 000000000000..caa4c507480c
--- /dev/null
+++ b/app-emulation/zsnes/zsnes-1.36.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ZSNES is a SNES (Super Nintendo) emulator that uses x86 assembly."
+SRC_URI="mirror://sourceforge/zsnes/zsnes136src.tar.gz"
+HOMEPAGE="http://www.zsnes.com/"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+
+src_compile() {
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
+}
+src_install () {
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.1
+ cd ${S}
+ dodoc *.txt linux/*
+}