summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-15 03:34:17 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-15 03:34:17 +0000
commitc1bb889d3bf0eb3d5bba74976623635c2e53cdb5 (patch)
treee5c78ebc51dd5887524f774a92dc6171972694dd /app-emulation
parentstick into testing for a bunch of arches (diff)
downloadhistorical-c1bb889d3bf0eb3d5bba74976623635c2e53cdb5.tar.gz
historical-c1bb889d3bf0eb3d5bba74976623635c2e53cdb5.tar.bz2
historical-c1bb889d3bf0eb3d5bba74976623635c2e53cdb5.zip
Version bump #88917 by Aaron Grubb.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog9
-rw-r--r--app-emulation/cedega/Manifest4
-rw-r--r--app-emulation/cedega/cedega-4.3.1.ebuild54
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.3.11
4 files changed, 65 insertions, 3 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 2a59c2342af1..0f990f91c850 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.12 2005/03/08 23:24:18 vapier Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.13 2005/04/15 03:34:17 vapier Exp $
+
+*cedega-4.3.1 (15 Apr 2005)
+
+ 15 Apr 2005; Mike Frysinger <vapier@gentoo.org> +cedega-4.3.1.ebuild:
+ Version bump #88917 by Aaron Grubb.
*cedega-4.3 (08 Mar 2005)
diff --git a/app-emulation/cedega/Manifest b/app-emulation/cedega/Manifest
index aeec3f7fb08e..e88ebcb428c4 100644
--- a/app-emulation/cedega/Manifest
+++ b/app-emulation/cedega/Manifest
@@ -1,10 +1,11 @@
-MD5 51689836b3ae260c7b460358b5a54524 ChangeLog 1473
+MD5 1d87173ff7ea540875e640466c44a184 ChangeLog 1613
MD5 7b1c828d8c9a9cca5440fa70caea5680 cedega-4.0.ebuild 1905
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
MD5 e4a39117202b3744850c0592dc7f2177 cedega-4.0.1.ebuild 1905
MD5 69560470d8537d86bfd06213349fa80f cedega-4.3.ebuild 1923
MD5 841b5f6906a8605901db52a034875936 cedega-4.1.1.ebuild 1904
MD5 d3ab1da6188cb7a94d2a52cdc4c402f4 cedega-4.1.ebuild 1902
+MD5 f978efe446d0c5d2595f9671b85307f6 cedega-4.3.1.ebuild 1925
MD5 0bd75fd1ef9fa58c1c01ad47fb472d41 cedega-4.2.1.ebuild 1904
MD5 33441edac7d54fe5bc520f90b115f444 cedega-4.2-r1.ebuild 1913
MD5 7eccc393a8bb2164b799f66650fc2b54 files/digest-cedega-4.0 67
@@ -14,3 +15,4 @@ MD5 73ddb9d92b6c018acae1f3bd69cc9b39 files/digest-cedega-4.1.1 69
MD5 e890dc2d0ab9f443ea98d5844990e38b files/digest-cedega-4.3 67
MD5 6f2852701a274200e814a6412c9b52e9 files/digest-cedega-4.2-r1 75
MD5 072ec142c269f7fb3c0d9add36d905eb files/digest-cedega-4.2.1 69
+MD5 076b966c6ab4b5f76ea6ca54b81abeac files/digest-cedega-4.3.1 69
diff --git a/app-emulation/cedega/cedega-4.3.1.ebuild b/app-emulation/cedega/cedega-4.3.1.ebuild
new file mode 100644
index 000000000000..02b28825d6b2
--- /dev/null
+++ b/app-emulation/cedega/cedega-4.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.3.1.ebuild,v 1.1 2005/04/15 03:34:17 vapier Exp $
+
+MY_P="cedega_${PV}-1.i386"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-4.3.1 b/app-emulation/cedega/files/digest-cedega-4.3.1
new file mode 100644
index 000000000000..9e89b1258c83
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-4.3.1
@@ -0,0 +1 @@
+MD5 801a7618c799e692c382f26d0af8f81f cedega_4.3.1-1.i386.tgz 7619848