summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-10 16:52:38 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-10 16:52:38 +0000
commitee69429f5fa0fbd8d2f0b2ab9e34619264c753c3 (patch)
tree97c5c2236bfc6e1c93f1ca977d938cf07e87017f /app-emulation
parentVersion bumped. (diff)
downloadhistorical-ee69429f5fa0fbd8d2f0b2ab9e34619264c753c3.tar.gz
historical-ee69429f5fa0fbd8d2f0b2ab9e34619264c753c3.tar.bz2
historical-ee69429f5fa0fbd8d2f0b2ab9e34619264c753c3.zip
Version bumped.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-workstation/Manifest4
-rw-r--r--app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.5.60302
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-4.0.5.6030.ebuild202
3 files changed, 206 insertions, 2 deletions
diff --git a/app-emulation/vmware-workstation/Manifest b/app-emulation/vmware-workstation/Manifest
index f2bc53955452..7d8dbe5f5fa5 100644
--- a/app-emulation/vmware-workstation/Manifest
+++ b/app-emulation/vmware-workstation/Manifest
@@ -1,8 +1,8 @@
-MD5 a61f0b8ddccba32062a4e8927cc92dfd ChangeLog 7406
+MD5 eed14fef3a809879bb2435d55a7ec4de ChangeLog 7562
MD5 fafe68703d58d3b50abe39c0fec6acfe metadata.xml 434
MD5 e039685acbfe77b547048c360ab0281c vmware-workstation-3.2.1.2242-r1.ebuild 6743
MD5 4d884bc893a8dcd05805c0ece1078f17 vmware-workstation-4.0.2.5592-r1.ebuild 6656
-MD5 dbd4451d2f6fe4c01fb7187993d44c2b vmware-workstation-4.0.5.6030.ebuild 6764
+MD5 9f400851f0631814779041b7edbf2762 vmware-workstation-4.0.5.6030.ebuild 6759
MD5 63e8db623fa8cd0faefe346e049d6fcf files/vmware.rc 1430
MD5 31f488383ededd4733e6317a62f2910f files/digest-vmware-workstation-3.2.1.2242-r1 158
MD5 c852454117950cc3bcda55bbf120e338 files/digest-vmware-workstation-4.0.2.5592-r1 158
diff --git a/app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.5.6030 b/app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.5.6030
new file mode 100644
index 000000000000..6202e552ef36
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/digest-vmware-workstation-4.0.5.6030
@@ -0,0 +1,2 @@
+MD5 3f2336ed95ee81aafbf8e40f9f4a0db7 VMware-workstation-4.0.5-6030.tar.gz 26222159
+MD5 ba28186d086a864fd8ae824d604fc9dc vmware-any-any-update41.tar.gz 189270
diff --git a/app-emulation/vmware-workstation/vmware-workstation-4.0.5.6030.ebuild b/app-emulation/vmware-workstation/vmware-workstation-4.0.5.6030.ebuild
new file mode 100644
index 000000000000..889e0c41bb6f
--- /dev/null
+++ b/app-emulation/vmware-workstation/vmware-workstation-4.0.5.6030.ebuild
@@ -0,0 +1,202 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-4.0.5.6030.ebuild,v 1.1 2003/10/10 16:52:33 mholzer Exp $
+
+# Unlike many other binary packages the user doesn't need to agree to a licence
+# to download VMWare. The agreeing to a licence is part of the configure step
+# which the user must run manually.
+
+inherit eutils
+
+S=${WORKDIR}/vmware-distrib
+N26KernSupport="vmware-any-any-update41"
+NP="VMware-workstation-4.0.5-6030"
+echo ${NP}
+DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators"
+HOMEPAGE="http://www.vmware.com/products/desktop/ws_features.html"
+SRC_URI="http://vmware-svca.www.conxion.com/software/wkst/${NP}.tar.gz
+ http://download3.vmware.com/software/wkst/${NP}.tar.gz
+ http://download.vmware.com/htdocs/software/wkst/${NP}.tar.gz
+ http://www.vmware.com/download1/software/wkst/${NP}.tar.gz
+ ftp://download1.vmware.com/pub/software/wkst/${NP}.tar.gz
+ http://vmware-chil.www.conxion.com/software/wkst/${NP}.tar.gz
+ http://vmware-heva.www.conxion.com/software/wkst/${NP}.tar.gz
+ http://vmware.wespe.de/software/wkst/${NP}.tar.gz
+ ftp://vmware.wespe.de/pub/software/wkst/${NP}.tar.gz
+ http://ftp.cvut.cz/vmware/${N26KernSupport}.tar.gz
+ http://knihovny.cvut.cz/ftp/pub/vmware/${N26KernSupport}.tar.gz"
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~x86"
+IUSE=""
+RESTRICT="nostrip"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ virtual/os-headers
+ >=dev-lang/perl-5
+ >=dev-lang/tcl-8.3.3
+ sys-apps/pciutils"
+
+src_unpack() {
+ check_KV
+ unpack ${NP}.tar.gz
+ if [ "${KV:0:3}" == "2.6" ] || [ "${KV:0:3}" == "2.5" ] ; then
+ einfo "Adding 2.{5,6}.x kernel support"
+ unpack ${N26KernSupport}.tar.gz
+ mv ${N26KernSupport}/*.tar ${S}/lib/modules/source/
+ else
+ einfo "Using 2.4.x kernel support"
+ fi
+}
+
+src_install() {
+ dodir /opt/vmware/bin
+ cp -a bin/* ${D}/opt/vmware/bin/
+ # vmware and vmware-ping needs to be suid root.
+ chmod u+s ${D}/opt/vmware/bin/vmware || die
+ chmod u+s ${D}/opt/vmware/bin/vmware-ping || die
+
+ dodir /opt/vmware/lib
+ cp -a lib/* ${D}/opt/vmware/lib/
+
+ chmod u+s ${D}/opt/vmware/lib/bin/vmware-vmx || die
+
+ # Since with Gentoo we compile everthing it doesn't make sense to keep
+ # the precompiled modules arround. Saves about 4 megs of disk space too.
+ rm -rf ${D}/opt/vmware/lib/modules/binary
+
+ dodir /opt/vmware/doc
+ cp -a doc/* ${D}/opt/vmware/doc/
+
+ dodir /opt/vmware/man/
+ cp -a man/* ${D}/opt/vmware/man/
+
+ # vmware service loader
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/vmware.rc vmware || die
+
+ # vmware enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/90vmware || die
+
+ dodir /etc/vmware/
+ cp -a etc/* ${D}/etc/vmware/
+
+ dodir /etc/vmware/init.d
+ dodir /etc/vmware/init.d/rc0.d
+ dodir /etc/vmware/init.d/rc1.d
+ dodir /etc/vmware/init.d/rc2.d
+ dodir /etc/vmware/init.d/rc3.d
+ dodir /etc/vmware/init.d/rc4.d
+ dodir /etc/vmware/init.d/rc5.d
+ dodir /etc/vmware/init.d/rc6.d
+ cp -a installer/services.sh ${D}/etc/vmware/init.d/vmware || die
+
+ # This is to fix a problem where if someone merges vmware and then
+ # before configuring vmware they upgrade or re-merge the vmware
+ # package which would rmdir the /etc/vmware/init.d/rc?.d directories.
+ keepdir /etc/vmware/init.d/rc{0,1,2,3,4,5,6}.d
+
+ # A simple icon I made
+ dodir /opt/vmware/lib/icon
+ insinto /opt/vmware/lib/icon
+ doins ${FILESDIR}/vmware.png || die
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/vmware.png || die
+
+ make_desktop_entry vmware "VMWare Workstation" vmware.png
+
+ dodir /usr/bin
+ dosym /opt/vmware/bin/vmware /usr/bin/vmware
+
+ # Questions:
+ einfo "Adding answers to /etc/vmware/locations"
+ locations="${D}/etc/vmware/locations"
+ echo "answer BINDIR /opt/vmware/bin" >> ${locations}
+ echo "answer LIBDIR /opt/vmware/lib" >> ${locations}
+ echo "answer MANDIR /opt/vmware/man" >> ${locations}
+ echo "answer DOCDIR /opt/vmware/doc" >> ${locations}
+ echo "answer RUN_CONFIGURATOR no" >> ${locations}
+ echo "answer INITDIR /etc/vmware/init.d" >> ${locations}
+ echo "answer INITSCRIPTSDIR /etc/vmware/init.d" >> ${locations}
+}
+
+pkg_preinst() {
+ # This must be done after the install to get the mtimes on each file
+ # right. This perl snippet gets the /etc/vmware/locations file code:
+ # perl -e "@a = stat('bin/vmware'); print \$a[9]"
+ # The above perl line and the find line below output the same thing.
+ # I would think the find line is faster to execute.
+ # find /opt/vmware/bin/vmware -printf %T@
+
+ #Note: it's a bit weird to use ${D} in a preinst script but it should work
+ #(drobbins, 1 Feb 2002)
+
+ einfo "Generating /etc/vmware/locations file."
+ d=`echo ${D} | wc -c`
+ for x in `find ${D}/opt/vmware ${D}/etc/vmware` ; do
+ x="`echo ${x} | cut -c ${d}-`"
+ if [ -d ${D}/${x} ] ; then
+ echo "directory ${x}" >> ${D}/etc/vmware/locations
+ else
+ echo -n "file ${x}" >> ${D}/etc/vmware/locations
+ if [ "${x}" == "/etc/vmware/locations" ] ; then
+ echo "" >> ${D}/etc/vmware/locations
+ elif [ "${x}" == "/etc/vmware/not_configured" ] ; then
+ echo "" >> ${D}/etc/vmware/locations
+ else
+ echo -n " " >> ${D}/etc/vmware/locations
+ #perl -e "@a = stat('${D}${x}'); print \$a[9]" >> ${D}/etc/vmware/locations
+ find ${D}${x} -printf %T@ >> ${D}/etc/vmware/locations
+ echo "" >> ${D}/etc/vmware/locations
+ fi
+ fi
+ done
+}
+
+pkg_config() {
+ # In case pkg_config() ends up being the defacto standard for
+ # configuring packages (malverian <malverian@gentoo.org>)
+
+ einfo "Running /opt/vmware/bin/vmware-config.pl"
+ /opt/vmware/bin/vmware-config.pl
+}
+
+pkg_postinst() {
+ # This is to fix the problem where the not_configured file doesn't get
+ # removed when the configuration is run. This doesn't remove the file
+ # It just tells the vmware-config.pl script it can delete it.
+ einfo "Updating /etc/vmware/locations"
+ for x in /etc/vmware/._cfg????_locations ; do
+ if [ -f $x ] ; then
+ cat $x >> /etc/vmware/locations
+ rm $x
+ fi
+ done
+
+ einfo
+ einfo "You need to run /opt/vmware/bin/vmware-config.pl to complete the install."
+ einfo
+ einfo "For VMware Add-Ons just visit"
+ einfo "http://www.vmware.com/download/downloadaddons.html"
+ einfo
+ einfo "After configuring, type 'vmware' to launch"
+ einfo
+ einfo "Also note that when you reboot you should run:"
+ einfo "/etc/init.d/vmware start"
+ einfo "before trying to run vmware. Or you could just add"
+ einfo "it to the default run level:"
+ einfo "rc-update add vmware default"
+ echo
+ ewarn "For users of glibc-2.3.x, vmware-nat support is *still* broken"
+}
+
+pkg_postrm() {
+ einfo
+ einfo "To remove all traces of vmware you will need to remove the files"
+ einfo "in /etc/vmware/, /etc/init.d/vmware, /lib/modules/*/misc/vm*.o,"
+ einfo "and .vmware/ in each users home directory."
+ einfo
+}