summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 00:59:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 00:59:58 +0000
commit019b483d5b226860c97396d5e4aa3a161e2fc2b1 (patch)
tree37b5eaf23b824a27d983c6a2e902e4daf5530646 /app-forensics/afflib
parentClean out -sharp 1.0 ebuilds (diff)
downloadhistorical-019b483d5b226860c97396d5e4aa3a161e2fc2b1.tar.gz
historical-019b483d5b226860c97396d5e4aa3a161e2fc2b1.tar.bz2
historical-019b483d5b226860c97396d5e4aa3a161e2fc2b1.zip
Initial import. Fixes #203758. Ebuild by raistlin@s0ftpj.org and aoz.syn@gmail.com.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-forensics/afflib')
-rw-r--r--app-forensics/afflib/ChangeLog11
-rw-r--r--app-forensics/afflib/Manifest4
-rw-r--r--app-forensics/afflib/afflib-3.3.4.ebuild43
-rw-r--r--app-forensics/afflib/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
new file mode 100644
index 000000000000..515cd7a3eaa2
--- /dev/null
+++ b/app-forensics/afflib/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-forensics/afflib
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.1 2009/03/01 00:59:58 patrick Exp $
+
+*afflib-3.3.4 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +afflib-3.3.4.ebuild:
+ Initial import. Fixes #203758. Ebuild by raistlin@s0ftpj.org and
+ aoz.syn@gmail.com.
+
diff --git a/app-forensics/afflib/Manifest b/app-forensics/afflib/Manifest
new file mode 100644
index 000000000000..f3c07be83b75
--- /dev/null
+++ b/app-forensics/afflib/Manifest
@@ -0,0 +1,4 @@
+DIST afflib-3.3.4.tar.gz 1894802 RMD160 ee64a8e312269348a90ece7edf517b0209a2d0c9 SHA1 e2dd28eb54ed325cead0e6f134f7b1811c87b5a0 SHA256 e87ff2b2dbcd74fa7d0bac370be8b18fab346f3b456d34be9baa325de646ea41
+EBUILD afflib-3.3.4.ebuild 1068 RMD160 4dccefb4ca2d9f9248879c22c24d13e9cd16bb13 SHA1 ceaac47ebfb311ca64c275670cb72990c1d75f08 SHA256 52f3d252422d9aa1a99847ce183aa07b5b7602d703f144023a730eac2482fc86
+MISC ChangeLog 421 RMD160 e56e1e5112bbe41b00e71276e53a36665c1b5c82 SHA1 afe814fbd28dde5797201d2a7017b557cf421d00 SHA256 1dfb9eb350068c90b00035ab588f10b1f52e73a15c79e8b9799e82bf93e426bc
+MISC metadata.xml 427 RMD160 fbadf41d1aa6825ee3b05ac54ca80eac45e501cf SHA1 3f33f0963f7b8680a4768dda492827cd4299ded1 SHA256 e9ae679aa792a4ba4172d7ccdd67d5fa35c0cb2a2f52c2b416b0a7ecbd154007
diff --git a/app-forensics/afflib/afflib-3.3.4.ebuild b/app-forensics/afflib/afflib-3.3.4.ebuild
new file mode 100644
index 000000000000..7c5ae7b75b92
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.3.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.3.4.ebuild,v 1.1 2009/03/01 00:59:58 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}
diff --git a/app-forensics/afflib/metadata.xml b/app-forensics/afflib/metadata.xml
new file mode 100644
index 000000000000..54ca968f91d0
--- /dev/null
+++ b/app-forensics/afflib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>forensics</herd>
+<maintainer>
+ <email>forensics@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="ewf">Enable libewf extra formats</flag>
+ <flag name="fuse">Enable extra fuse thingies</flag>
+ <flag name="qemu">Enable qemu stuff</flag>
+ <flag name="s3">Enable S3</flag>
+
+</use>
+</pkgmetadata>