summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-10 18:00:41 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-10 18:00:41 +0000
commite34545d56baa5754ef277adfc43918c61fc7792f (patch)
tree6f552daac4a3d9d4180b7fa24006732f45018e8e /app-i18n/anthy-ss
parentVersion bumped (diff)
downloadhistorical-e34545d56baa5754ef277adfc43918c61fc7792f.tar.gz
historical-e34545d56baa5754ef277adfc43918c61fc7792f.tar.bz2
historical-e34545d56baa5754ef277adfc43918c61fc7792f.zip
Version bumped
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/Manifest2
-rw-r--r--app-i18n/anthy-ss/anthy-ss-4609.ebuild71
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-46091
3 files changed, 73 insertions, 1 deletions
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index cbb1fea33579..ae83fd423d0c 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,4 +1,4 @@
-MD5 b79ec703bdff880ec3d69c5dc9e2a138 anthy-ss-4609.ebuild 1521
+MD5 317a8174f6bc80ea4daeae37e3f89e8b anthy-ss-4609.ebuild 1521
MD5 b448f83cf0b7c04260de08ce95b30805 anthy-ss-4524.ebuild 1502
MD5 ca30b7ef075f2fc650499a1a074aa91f metadata.xml 818
MD5 2a9d6ba5f1eb1ba2651d8b2ea80ed21e ChangeLog 766
diff --git a/app-i18n/anthy-ss/anthy-ss-4609.ebuild b/app-i18n/anthy-ss/anthy-ss-4609.ebuild
new file mode 100644
index 000000000000..0b64d426b3c4
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-4609.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-4609.ebuild,v 1.1 2003/10/10 18:00:37 usata Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/6297/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~sparc ~ppc"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-4609 b/app-i18n/anthy-ss/files/digest-anthy-ss-4609
new file mode 100644
index 000000000000..a7ff72d966df
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-4609
@@ -0,0 +1 @@
+MD5 33556bcf4ffde4c85231fc603fc20bc9 anthy-4609.tar.gz 1419258