summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-13 13:33:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-13 13:33:28 +0000
commitd83f45c22b0a676b014003da02d281645a89b3f5 (patch)
tree0d7b3a7485c6f9928fb45d6f685958d0b809f79e /app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
parentBump to ruby-fakegem. (diff)
downloadhistorical-d83f45c22b0a676b014003da02d281645a89b3f5.tar.gz
historical-d83f45c22b0a676b014003da02d281645a89b3f5.tar.bz2
historical-d83f45c22b0a676b014003da02d281645a89b3f5.zip
Version bumped.
Package-Manager: portage-2.1.7.16/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild')
-rw-r--r--app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild b/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
new file mode 100644
index 000000000000..372ab4982cc4
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-0.0.4.ebuild,v 1.1 2010/01/13 13:33:28 matsuu Exp $
+
+EAPI="2"
+
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="app-i18n/ibus
+ >=dev-lang/python-2.5
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}