summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-22 21:19:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-22 21:19:08 +0000
commita7e613f1ae6e82e7bb10116f9a536a64eeea062f (patch)
tree708025030953a0d5b247797f8ab9a698775bfb4b /app-i18n/scim-tomoe
parentBump to 0.6.0-r1. Fix build with gucharmap-2.24, bug #243160. Make gucharmap ... (diff)
downloadhistorical-a7e613f1ae6e82e7bb10116f9a536a64eeea062f.tar.gz
historical-a7e613f1ae6e82e7bb10116f9a536a64eeea062f.tar.bz2
historical-a7e613f1ae6e82e7bb10116f9a536a64eeea062f.zip
Bump to 0.6.0-r2. Fix build with gucharmap-2.24, bug #243160. Add gucharmap to RDEPEND, bug #249753.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/scim-tomoe')
-rw-r--r--app-i18n/scim-tomoe/ChangeLog12
-rw-r--r--app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch21
-rw-r--r--app-i18n/scim-tomoe/metadata.xml3
-rw-r--r--app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild38
4 files changed, 72 insertions, 2 deletions
diff --git a/app-i18n/scim-tomoe/ChangeLog b/app-i18n/scim-tomoe/ChangeLog
index bda0c099afec..5cf6ad302d49 100644
--- a/app-i18n/scim-tomoe/ChangeLog
+++ b/app-i18n/scim-tomoe/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/scim-tomoe
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tomoe/ChangeLog,v 1.10 2008/09/23 16:08:11 matsuu Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tomoe/ChangeLog,v 1.11 2009/02/22 21:19:07 eva Exp $
+
+*scim-tomoe-0.6.0-r2 (22 Feb 2009)
+
+ 22 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/scim-tomoe-0.6.0-gucharmap2.patch, metadata.xml,
+ +scim-tomoe-0.6.0-r2.ebuild:
+ Bump to 0.6.0-r2. Fix build with gucharmap-2.24, bug #243160. Add
+ gucharmap to RDEPEND, bug #249753.
*scim-tomoe-0.6.0-r1 (23 Sep 2008)
diff --git a/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch
new file mode 100644
index 000000000000..0444bb2e6dd9
--- /dev/null
+++ b/app-i18n/scim-tomoe/files/scim-tomoe-0.6.0-gucharmap2.patch
@@ -0,0 +1,21 @@
+---
+ Update libtomoe-gtk to gucharmap-2 API
+ https://bugs.gentoo.org/show_bug.cgi?id=243160
+
+ scim_tomoe_prefs_widget.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/src/scim_tomoe_prefs_widget.cpp 2008-12-06 16:40:15.000000000 +0100
++++ b/src/scim_tomoe_prefs_widget.cpp 2008-12-06 17:01:19.000000000 +0100
+@@ -473,9 +473,9 @@
+ String (SCIM_TOMOE_CONFIG_UNICODE_TABLE_FONT_DEFAULT));
+
+ if (font.length() > 0) {
+- gucharmap_charmap_set_font (charmap, font.c_str ());
++ gucharmap_charmap_set_font_desc (charmap, pango_font_description_from_string(font.c_str ()));
+ } else {
+- gucharmap_charmap_set_font (charmap, NULL);
++ gucharmap_charmap_set_font_desc (charmap, pango_font_description_from_string(NULL));
+ set_default_font (prefs, SCIM_TOMOE_CONFIG_CAND_FONT,
+ GTK_WIDGET (charmap));
+ }
diff --git a/app-i18n/scim-tomoe/metadata.xml b/app-i18n/scim-tomoe/metadata.xml
index 51689f0cbcb5..0f7257ad54e8 100644
--- a/app-i18n/scim-tomoe/metadata.xml
+++ b/app-i18n/scim-tomoe/metadata.xml
@@ -2,5 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>cjk</herd>
+<use>
+ <flag name="gucharmap">Enable gucharmap dictionary plugin</flag>
+</use>
</pkgmetadata>
diff --git a/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..12b14f229b43
--- /dev/null
+++ b/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-tomoe/scim-tomoe-0.6.0-r2.ebuild,v 1.1 2009/02/22 21:19:07 eva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Japanese input method Tomoe IMEngine for SCIM"
+HOMEPAGE="http://tomoe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tomoe/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gucharmap"
+
+RDEPEND=">=app-i18n/scim-1.2.0
+ >=app-i18n/libtomoe-gtk-0.6.0[gucharmap=]
+ gucharmap? ( >=gnome-extra/gucharmap-1.4 )
+ >=x11-libs/gtk+-2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+src_prepare() {
+ # Fix build with gcc-4.3, bug #
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+ # Fix build with gucharmap-2.24, bug #243160
+ epatch "${FILESDIR}/${P}-gucharmap2.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}