summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-09-20 00:04:05 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-09-20 00:04:05 +0000
commit35de7d2a4c75498241e55c19d2d53c9bb8674561 (patch)
treec2f847ebf1f0f27bea225cbd5095e4f5263a40a1 /app-i18n/skktools/skktools-1.2-r1.ebuild
parentAdded 2.6.23_rc7. (diff)
downloadhistorical-35de7d2a4c75498241e55c19d2d53c9bb8674561.tar.gz
historical-35de7d2a4c75498241e55c19d2d53c9bb8674561.tar.bz2
historical-35de7d2a4c75498241e55c19d2d53c9bb8674561.zip
Fixed bug #193121. the patch is from debian.
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'app-i18n/skktools/skktools-1.2-r1.ebuild')
-rw-r--r--app-i18n/skktools/skktools-1.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/skktools/skktools-1.2-r1.ebuild b/app-i18n/skktools/skktools-1.2-r1.ebuild
new file mode 100644
index 000000000000..bec7701e3254
--- /dev/null
+++ b/app-i18n/skktools/skktools-1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/skktools/skktools-1.2-r1.ebuild,v 1.1 2007/09/20 00:04:04 matsuu Exp $
+
+inherit elisp-common eutils
+
+DESCRIPTION="SKK utilities to manage dictionaries"
+HOMEPAGE="http://openlab.jp/skk/"
+SRC_URI="http://openlab.ring.gr.jp/skk/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ruby emacs"
+
+DEPEND="virtual/libc
+ >=dev-libs/glib-2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-CVE-2007-3916.patch
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ use ruby && dobin saihenkan.rb
+ use emacs && elisp-site-file-install skk-xml.el
+
+ insinto /usr/share/skk
+ doins unannotation.awk
+
+ dodoc ChangeLog README READMEs/*
+}