summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-14 10:43:31 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-14 10:43:31 +0000
commit9f21de94cbf6b29df676d91988591cfead64c1a1 (patch)
treef0a1a6111d55bd47bb8dbff65675e62bf72ee0d8 /app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild
parentUse make DESTDIR install instead of einstall, fixes sandbox violation reporte... (diff)
downloadhistorical-9f21de94cbf6b29df676d91988591cfead64c1a1.tar.gz
historical-9f21de94cbf6b29df676d91988591cfead64c1a1.tar.bz2
historical-9f21de94cbf6b29df676d91988591cfead64c1a1.zip
Fix econf call for non-autotools configure, fix quoting, remove pregenerated depfile to fix bug #151282, reported by Patrick Lauer.
Package-Manager: portage-2.1.2_pre3
Diffstat (limited to 'app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild')
-rw-r--r--app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild b/app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild
index f477db8a58d0..973772768232 100644
--- a/app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild
+++ b/app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild,v 1.2 2006/08/27 14:36:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xvnkb/xvnkb-0.2.8a-r1.ebuild,v 1.3 2006/10/14 10:43:31 flameeyes Exp $
inherit eutils
@@ -22,11 +22,13 @@ DEPEND="${RDEPEND} || ( ( x11-proto/xproto ) virtual/x11 )"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}.patch
- epatch ${FILESDIR}/${PV}-putenv.patch
-}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/${PV}-putenv.patch"
+ # Remove pregenerated dep file.
+ rm -f "${S}/tools/Makefile.dep"
+}
src_compile() {
local myconf
@@ -34,9 +36,12 @@ src_compile() {
use spell || myconf="${myconf} --no-spellcheck"
use truetype || myconf="${myconf} --no-xft"
- econf --use-extstroke ${myconf} || die
+ # *not* autotools
+ ./configure \
+ --use-extstroke ${myconf} \
+ || die "./configure failed"
- emake || die
+ emake || die "emake failed"
}
src_install() {