summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 02:38:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 02:38:16 +0000
commita4b49b2ebd4a3ebefb07cf24f670ac362d03d678 (patch)
tree3216669d8ca989ed2bcb60cf70c814f5897ca489 /app-laptop/tpctl/tpctl-4.4-r1.ebuild
parentAdded ~mips. Fixed CXXFLAGS so that non-x86 builds work. QA: added IUSE. (diff)
downloadhistorical-a4b49b2ebd4a3ebefb07cf24f670ac362d03d678.tar.gz
historical-a4b49b2ebd4a3ebefb07cf24f670ac362d03d678.tar.bz2
historical-a4b49b2ebd4a3ebefb07cf24f670ac362d03d678.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-laptop/tpctl/tpctl-4.4-r1.ebuild')
-rw-r--r--app-laptop/tpctl/tpctl-4.4-r1.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/app-laptop/tpctl/tpctl-4.4-r1.ebuild b/app-laptop/tpctl/tpctl-4.4-r1.ebuild
index b7d6cf731c00..332553a98357 100644
--- a/app-laptop/tpctl/tpctl-4.4-r1.ebuild
+++ b/app-laptop/tpctl/tpctl-4.4-r1.ebuild
@@ -1,35 +1,37 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.4-r1.ebuild,v 1.2 2004/06/24 22:00:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.4-r1.ebuild,v 1.3 2004/06/28 02:37:53 vapier Exp $
-IUSE="ncurses tpctlir perl"
+inherit eutils
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
MYP="${PN}_${MYPV}"
DESCRIPTION="Thinkpad system control user space programs"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="-* x86 amd64"
-SLOT="0"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+IUSE="ncurses tpctlir perl"
-DEPEND=">=app-laptop/thinkpad-4.3 ncurses? ( sys-libs/ncurses )"
-RDEPEND=">=app-laptop/thinkpad-4.3 ncurses? ( sys-libs/ncurses )
+DEPEND=">=app-laptop/thinkpad-4.3
+ ncurses? ( sys-libs/ncurses )"
+RDEPEND="${DEPEND}
perl? ( dev-lang/perl )"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/tpctlir-cli-4.4-r1.diff
+ epatch ${FILESDIR}/tpctlir-cli-4.4-r1.diff
}
src_compile() {
-
emake -C lib || die "lib make failed"
emake -C tpctl || die "tpctl make failed"
- if use ncurses > /dev/null; then
+ if use ncurses ; then
emake -C ntpctl || die "ntpctl make failed"
fi
@@ -42,8 +44,7 @@ src_compile() {
}
src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
- VGA-MODES
+ dodoc AUTHORS ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING VGA-MODES
dolib lib/libsmapidev.so.2.0
dobin tpctl/tpctl
[ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
@@ -52,7 +53,7 @@ src_install() {
dodoc README.tpctlir
dobin tpctlir/tpctlir
fi
- if use perl > /dev/null; then
+ if use perl ; then
mv apmiser/README README.apmiser
dodoc README.apmiser
dosbin apmiser/apmiser