summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 11:49:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 11:49:47 +0000
commitef40417cafc11045cf7209435c52b07ceb510493 (patch)
treeb7a6f16ca5351bc85b5d6b4e70e66030bdf56736 /app-misc/getopt/files
parentAdd visibility patch to enable KDE hidden visibility. Enable only in presence... (diff)
downloadhistorical-ef40417cafc11045cf7209435c52b07ceb510493.tar.gz
historical-ef40417cafc11045cf7209435c52b07ceb510493.tar.bz2
historical-ef40417cafc11045cf7209435c52b07ceb510493.zip
Add getopt package providing getopt-long for platforms where getopt(1) does not support GNU style long options.
Package-Manager: portage-2.1_rc2-r2
Diffstat (limited to 'app-misc/getopt/files')
-rw-r--r--app-misc/getopt/files/digest-getopt-1.1.43
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-libintl.patch34
-rw-r--r--app-misc/getopt/files/getopt-1.1.4-longrename.patch118
3 files changed, 155 insertions, 0 deletions
diff --git a/app-misc/getopt/files/digest-getopt-1.1.4 b/app-misc/getopt/files/digest-getopt-1.1.4
new file mode 100644
index 000000000000..13d586c2a340
--- /dev/null
+++ b/app-misc/getopt/files/digest-getopt-1.1.4
@@ -0,0 +1,3 @@
+MD5 02188ca68da27c4175d6e9f3da732101 getopt-1.1.4.tar.gz 37163
+RMD160 79fffccf1b48956bfc1fbb19c22c2d94adf10dff getopt-1.1.4.tar.gz 37163
+SHA256 41083d9993c26792851e79b81a0991996a3f61e14998fdd607615cc3bf933bab getopt-1.1.4.tar.gz 37163
diff --git a/app-misc/getopt/files/getopt-1.1.4-libintl.patch b/app-misc/getopt/files/getopt-1.1.4-libintl.patch
new file mode 100644
index 000000000000..232e487b3d31
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.4-libintl.patch
@@ -0,0 +1,34 @@
+Index: getopt-1.1.4/Makefile
+===================================================================
+--- getopt-1.1.4.orig/Makefile
++++ getopt-1.1.4/Makefile
+@@ -33,7 +33,10 @@ MSGFMT=msgfmt
+ LANGUAGES = cs de es fr it ja nl pt_BR
+ MOFILES:=$(patsubst %,po/%.mo,$(LANGUAGES))
+
+-CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DWITH_GETTEXT=$(WITH_GETTEXT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX
++CPPFLAGS=-DLIBCGETOPT=$(LIBCGETOPT) -DLOCALEDIR=\"$(localedir)\" -DNOT_UTIL_LINUX
++ifeq ($(WITHOUT_GETTEXT),1)
++CPPFLAGS+=-DWITHOUT_GETTEXT
++endif
+ ifeq ($(LIBCGETOPT),0)
+ CPPFLAGS+=-I./gnu
+ endif
+@@ -62,7 +65,7 @@ clean: clean_po
+ -$(RM) $(objects) $(binaries)
+
+ getopt: $(objects)
+- $(CC) $(LDFLAGS) -o $@ $(objects)
++ $(CC) $(LDFLAGS) -o $@ $(objects) $(LIBINTL)
+
+ install: getopt install_po
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
+@@ -75,7 +78,7 @@ install_doc:
+ getopt-test.bash getopt-test.tcsh \
+ $(DESTDIR)$(getoptdir)
+
+-ifeq ($(WITH_GETTEXT),1)
++ifeq ($(WITHOUT_GETTEXT),0)
+ all_po: $(MOFILES)
+ install_po: all_po
+ $(INSTALL) -m 755 -d $(DESTDIR)$(localedir)
diff --git a/app-misc/getopt/files/getopt-1.1.4-longrename.patch b/app-misc/getopt/files/getopt-1.1.4-longrename.patch
new file mode 100644
index 000000000000..dc3ecb066378
--- /dev/null
+++ b/app-misc/getopt/files/getopt-1.1.4-longrename.patch
@@ -0,0 +1,118 @@
+Index: getopt-1.1.4/getopt.c
+===================================================================
+--- getopt-1.1.4.orig/getopt.c
++++ getopt-1.1.4/getopt.c
+@@ -88,7 +88,7 @@ void *our_malloc(size_t size)
+ {
+ void *ret=malloc(size);
+ if (! ret) {
+- fprintf(stderr,_("%s: Out of memory!\n"),"getopt");
++ fprintf(stderr,_("%s: Out of memory!\n"),"getopt-long");
+ exit(3);
+ }
+ return(ret);
+@@ -98,7 +98,7 @@ void *our_realloc(void *ptr, size_t size
+ {
+ void *ret=realloc(ptr,size);
+ if (! ret && size) {
+- fprintf(stderr,_("%s: Out of memory!\n"),"getopt");
++ fprintf(stderr,_("%s: Out of memory!\n"),"getopt-long");
+ exit(3);
+ }
+ return(ret);
+@@ -231,8 +231,8 @@ int generate_output(char * argv[],int ar
+ void parse_error(const char *message)
+ {
+ if (message)
+- fprintf(stderr,"getopt: %s\n",message);
+- fputs(_("Try `getopt --help' for more information.\n"),stderr);
++ fprintf(stderr,"getopt-long: %s\n",message);
++ fputs(_("Try `getopt-long --help' for more information.\n"),stderr);
+ exit(2);
+ }
+
+@@ -323,10 +323,10 @@ void set_shell(const char *new_shell)
+
+ void print_help(void)
+ {
+- fputs(_("Usage: getopt optstring parameters\n"),stderr);
+- fputs(_(" getopt [options] [--] optstring parameters\n"),stderr);
+- fputs(_(" getopt [options] -o|--options optstring [options] [--]\n"),stderr);
+- fputs(_(" parameters\n"),stderr);
++ fputs(_("Usage: getopt-long optstring parameters\n"),stderr);
++ fputs(_(" getopt-long [options] [--] optstring parameters\n"),stderr);
++ fputs(_(" getopt-long [options] -o|--options optstring [options] [--]\n"),stderr);
++ fputs(_(" parameters\n"),stderr);
+ fputs(_(" -a, --alternative Allow long options starting with single -\n"),stderr);
+ fputs(_(" -h, --help This small usage guide\n"),stderr);
+ fputs(_(" -l, --longoptions=longopts Long options to be recognized\n"),stderr);
+@@ -335,7 +335,7 @@ void print_help(void)
+ fputs(_(" -q, --quiet Disable error reporting by getopt(3)\n"),stderr);
+ fputs(_(" -Q, --quiet-output No normal output\n"),stderr);
+ fputs(_(" -s, --shell=shell Set shell quoting conventions\n"),stderr);
+- fputs(_(" -T, --test Test for getopt(1) version\n"),stderr);
++ fputs(_(" -T, --test Test for getopt-long(1) version\n"),stderr);
+ fputs(_(" -u, --unqote Do not quote the output\n"),stderr);
+ fputs(_(" -V, --version Output version information\n"),stderr);
+ exit(2);
+@@ -443,7 +443,7 @@ int main(int argc, char *argv[])
+ quote=0;
+ break;
+ case 'V':
+- printf(_("getopt (enhanced) 1.1.4\n"));
++ printf(_("getopt-long (enhanced) 1.1.4\n"));
+ exit(0);
+ case '?':
+ case ':':
+Index: getopt-1.1.4/getopt-parse.bash
+===================================================================
+--- getopt-1.1.4.orig/getopt-parse.bash
++++ getopt-1.1.4/getopt-parse.bash
+@@ -19,7 +19,7 @@
+ # Note that we use `"$@"' to let each command-line parameter expand to a
+ # separate word. The quotes around `$@' are essential!
+ # We need TEMP as the `eval set --' would nuke the return value of getopt.
+-TEMP=`getopt -o ab:c:: --long a-long,b-long:,c-long:: \
++TEMP=`getopt-long -o ab:c:: --long a-long,b-long:,c-long:: \
+ -n 'example.bash' -- "$@"`
+
+ if [ $? != 0 ] ; then echo "Terminating..." >&2 ; exit 1 ; fi
+Index: getopt-1.1.4/getopt-parse.tcsh
+===================================================================
+--- getopt-1.1.4.orig/getopt-parse.tcsh
++++ getopt-1.1.4/getopt-parse.tcsh
+@@ -26,7 +26,7 @@
+ # as a list. The ':q` copies that list without doing any substitutions:
+ # each element of argv becomes a separate argument for getopt. The braces
+ # are needed because the result is also a list.
+-set temp=(`getopt -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
++set temp=(`getopt-long -s tcsh -o ab:c:: --long a-long,b-long:,c-long:: -- $argv:q`)
+ if ($? != 0) then
+ echo "Terminating..." >/dev/stderr
+ exit 1
+Index: getopt-1.1.4/Makefile
+===================================================================
+--- getopt-1.1.4.orig/Makefile
++++ getopt-1.1.4/Makefile
+@@ -85,7 +85,7 @@ install_po: all_po
+ for lang in $(LANGUAGES) ; do \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(INSTALL) -m 755 -d $(DESTDIR)$$dir ;\
+- $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt.mo ;\
++ $(INSTALL) -m 644 po/$$lang.mo $(DESTDIR)$$dir/getopt-long.mo ;\
+ done
+ clean_po:
+ $(RM) $(MOFILES)
+Index: getopt-1.1.4/nls.h
+===================================================================
+--- getopt-1.1.4.orig/nls.h
++++ getopt-1.1.4/nls.h
+@@ -29,7 +29,7 @@
+ #ifndef GETOPT_NLS
+ #define GETOPT_NLS
+
+-#define PACKAGE "getopt"
++#define PACKAGE "getopt-long"
+
+ #ifndef WITHOUT_GETTEXT
+ #include <libintl.h>