summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-13 12:46:30 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-13 12:46:30 +0000
commit4cec1025ffac6038fe9beaa64bf77a6fd209b4db (patch)
tree49808f2d211c3568f4ed6177c4a44393fa8f6ba5 /app-misc/glimpse/glimpse-4.18.5.ebuild
parentMarked ppc stable for bug #325825. (diff)
downloadhistorical-4cec1025ffac6038fe9beaa64bf77a6fd209b4db.tar.gz
historical-4cec1025ffac6038fe9beaa64bf77a6fd209b4db.tar.bz2
historical-4cec1025ffac6038fe9beaa64bf77a6fd209b4db.zip
Patch from Dane Smith <smithdanea@gmail.com> to fix LDFLAGS and parallel build issues. Bug #332463
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'app-misc/glimpse/glimpse-4.18.5.ebuild')
-rw-r--r--app-misc/glimpse/glimpse-4.18.5.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-misc/glimpse/glimpse-4.18.5.ebuild b/app-misc/glimpse/glimpse-4.18.5.ebuild
index 8fde84feadcb..8ce99c43d84d 100644
--- a/app-misc/glimpse/glimpse-4.18.5.ebuild
+++ b/app-misc/glimpse/glimpse-4.18.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.18.5.ebuild,v 1.13 2010/01/01 21:17:05 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.18.5.ebuild,v 1.14 2010/08/13 12:46:30 hwoarang Exp $
inherit flag-o-matic eutils
@@ -27,20 +27,26 @@ src_unpack() {
sed -i \
-e '/^CFLAGS/s:$: $(OPTIMIZEFLAGS):' \
{agrep,compress,index}/Makefile.in \
- Makefile.in \
libtemplate/{template,util}/Makefile.in \
|| die "inserting OPTIMIZEFLAGS failed"
sed -i \
-e 's:$(mandir):&/man1/:' \
- Makefile.in agrep/Makefile.in \
+ agrep/Makefile.in \
|| die "adding man1 to man install dir failed"
+
+ sed -i \
+ -e '/^LDFLAGS/d' \
+ {agrep,compress,index}/Makefile.in \
+ || die "LDFLAGS sed failed"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
}
src_compile() {
use static && append-ldflags -static
econf || die
- emake -j1 OPTIMIZEFLAGS="${CFLAGS}" || die
+ emake OPTIMIZEFLAGS="${CFLAGS}" || die
}
src_install() {