summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 04:18:52 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 04:18:52 +0000
commitdf5dbac64793120bd42de7e388374590da2b5287 (patch)
tree90f06c3d21bf3f66510acc04e4f0c7084b424bb9 /app-misc/pal/pal-0.3.4.ebuild
parentunmask baselayout-1.10 (diff)
downloadhistorical-df5dbac64793120bd42de7e388374590da2b5287.tar.gz
historical-df5dbac64793120bd42de7e388374590da2b5287.tar.bz2
historical-df5dbac64793120bd42de7e388374590da2b5287.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/pal/pal-0.3.4.ebuild')
-rw-r--r--app-misc/pal/pal-0.3.4.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-misc/pal/pal-0.3.4.ebuild b/app-misc/pal/pal-0.3.4.ebuild
index 7857c3e8ea31..56e49ad27c77 100644
--- a/app-misc/pal/pal-0.3.4.ebuild
+++ b/app-misc/pal/pal-0.3.4.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pal/pal-0.3.4.ebuild,v 1.3 2004/06/24 22:28:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pal/pal-0.3.4.ebuild,v 1.4 2004/06/28 04:07:45 vapier Exp $
-IUSE=""
DESCRIPTION="pal command-line calendar program"
-SRC_URI="mirror://sourceforge/palcal/${P}.tgz"
HOMEPAGE="http://palcal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/palcal/${P}.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-
-S="${WORKDIR}/${P}/src"
+IUSE=""
DEPEND=">=dev-libs/glib-2.0
sys-devel/gettext
- virtual/glibc
+ virtual/libc
sys-libs/readline"
+S="${WORKDIR}/${P}/src"
+
src_unpack() {
- unpack "${A}"
- cd "${S}"
+ unpack ${A}
+ cd ${S}
sed -i -e "s;^\(OPT[[:space:]]\+=\) -O2 -Wall;\1 ${CFLAGS};" Makefile.defs
}
@@ -31,4 +31,3 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install-no-rm || die "make install failed"
}
-