summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-01-22 00:13:08 +0000
committerRyan Hill <rhill@gentoo.org>2007-01-22 00:13:08 +0000
commitd7e9058aa157a4cec8bc55a066853307c871a57c (patch)
tree5098e4848cf14f2c82a8bfb17a47754f1a77d0dd /app-misc/when/when-1.0.23.ebuild
parent2.1.2-r2 revbump. Bug #162453 tracks fixes since 2.1.2. (diff)
downloadhistorical-d7e9058aa157a4cec8bc55a066853307c871a57c.tar.gz
historical-d7e9058aa157a4cec8bc55a066853307c871a57c.tar.bz2
historical-d7e9058aa157a4cec8bc55a066853307c871a57c.zip
Undo last revision and apply patch by James Rowe to fix tests (bug #138415).
Package-Manager: portage-2.1.2-r1
Diffstat (limited to 'app-misc/when/when-1.0.23.ebuild')
-rw-r--r--app-misc/when/when-1.0.23.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/app-misc/when/when-1.0.23.ebuild b/app-misc/when/when-1.0.23.ebuild
index 1c90e7ab6f62..c854e8c074ed 100644
--- a/app-misc/when/when-1.0.23.ebuild
+++ b/app-misc/when/when-1.0.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/when/when-1.0.23.ebuild,v 1.6 2007/01/19 04:48:21 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/when/when-1.0.23.ebuild,v 1.7 2007/01/22 00:13:08 dirtyepic Exp $
DESCRIPTION="Extremely simple personal calendar program aimed at the Unix geek who wants something minimalistic"
HOMEPAGE="http://www.lightandmatter.com/when/when.html"
@@ -13,12 +13,24 @@ IUSE=""
RDEPEND=">=dev-lang/perl-5.005"
-RESTRICT="test"
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile
+}
src_compile() {
emake ${PN}.html || die "emake failed"
}
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir ${HOME}/.when
+ touch ${HOME}/.when/{calendar,preferences}
+ emake test || die "emake test failed"
+}
+
src_install() {
dobin ${PN} || die "dobin failed"
doman ${PN}.1 || die "doman failed"