summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-12-26 18:29:17 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-12-26 18:29:17 +0000
commitd75ab47d092b8c5ef94c299e01e9b0ed81c1706b (patch)
tree0c1f53ddda367cc064cf6868fcf196d52bce9944 /app-misc
parentadding patch from ciaranm, and some additional docs from author. (diff)
downloadhistorical-d75ab47d092b8c5ef94c299e01e9b0ed81c1706b.tar.gz
historical-d75ab47d092b8c5ef94c299e01e9b0ed81c1706b.tar.bz2
historical-d75ab47d092b8c5ef94c299e01e9b0ed81c1706b.zip
adding patch from ciaranm, and some additional docs from author.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/mtail/Manifest4
-rw-r--r--app-misc/mtail/files/digest-mtail-1.1.1-r12
-rw-r--r--app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch52
-rw-r--r--app-misc/mtail/mtail-1.1.1-r1.ebuild29
4 files changed, 85 insertions, 2 deletions
diff --git a/app-misc/mtail/Manifest b/app-misc/mtail/Manifest
index a2fede2b3073..2361134c863a 100644
--- a/app-misc/mtail/Manifest
+++ b/app-misc/mtail/Manifest
@@ -1,6 +1,6 @@
-MD5 5295b63467099f1e0a1e55f531dd8d04 mtail-1.1.1-r1.ebuild 755
+MD5 aed11d5e15aee7c8028bd9e1f28f5afc mtail-1.1.1-r1.ebuild 771
MD5 e9521d2616d61972fe6ebe7550f3d449 mtail-1.1.1.ebuild 586
-MD5 e9bf89055f957d964f45414e7b83d6e9 ChangeLog 522
+MD5 08dc9e3f30d169d054ae12d0a3f3d9ee ChangeLog 718
MD5 d8d8d641e0e3ddcd194f2d82609bdd8c metadata.xml 1580
MD5 d53c96ae2db32498bc23b9f5ee342a5d files/digest-mtail-1.1.1 58
MD5 55e03d3434a0e7bbdffb7a1db35434e7 files/digest-mtail-1.1.1-r1 122
diff --git a/app-misc/mtail/files/digest-mtail-1.1.1-r1 b/app-misc/mtail/files/digest-mtail-1.1.1-r1
new file mode 100644
index 000000000000..90fbe50ac8c9
--- /dev/null
+++ b/app-misc/mtail/files/digest-mtail-1.1.1-r1
@@ -0,0 +1,2 @@
+MD5 166ccd3bfea04fdc81940b256d7d6f18 mtail-1.1.1.tgz 9124
+MD5 6a66666049b399b07dc0b263fdb47b28 mtailrc-syslog.sample 1785
diff --git a/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch b/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch
new file mode 100644
index 000000000000..9645e263deda
--- /dev/null
+++ b/app-misc/mtail/files/mtail-1.1.1-remove-blanks.patch
@@ -0,0 +1,52 @@
+--- mtail.orig 2003-11-07 19:02:34.000000000 +0000
++++ mtail 2003-11-07 19:19:18.000000000 +0000
+@@ -46,6 +46,7 @@
+ verbose = 0
+ silent = 0
+ active = 0
++remove_blanks = 0
+
+ # sets up the interrupt handler, calls processargs(), sets up and starts the
+ # tailers.
+@@ -119,6 +120,8 @@
+ if line[len(line)-1] == '\n':
+ line = line[:len(line)-1]
+ line = filter(line)
++ if remove_blanks and not line:
++ continue
+ lock.acquire()
+ try:
+ if (multiple or verbose) and (not silent) \
+@@ -138,12 +141,14 @@
+ global verbose
+ global silent
+ global config_file
++ global remove_blanks
+ filenames = []
+ lines = None
+ follow = 0
+ try:
+ opts, pargs = getopt.getopt(sys.argv[1:], 'fn:?hvq', ["follow",
+- "lines=", "help", "verbose", "quiet", "silent", "config="])
++ "lines=", "help", "verbose", "quiet", "silent", "config=",
++ "remove-blanks"])
+ except getopt.error:
+ print 'unrecognized option!'
+ print
+@@ -163,6 +168,8 @@
+ silent = 1
+ elif opt[0] in ['--config']:
+ config_file = opt[1]
++ elif opt[0] in ['--remove-blanks']:
++ remove_blanks = 1
+ if lines == None:
+ lines = 10
+ for filename in pargs:
+@@ -186,6 +193,7 @@
+ print ' -v, --verbose always output headers giving file names'
+ print ' -q, --quiet, --silent never output headers giving file names'
+ print ' --config=FILE use config file FILE instead of ~/.mtailrc'
++ print ' --remove-blanks do not display blank lines'
+ print
+ print 'with more than one filename, mtail will precede each chunk from'
+ print 'each with a header giving the file name. if no filenames are given'
diff --git a/app-misc/mtail/mtail-1.1.1-r1.ebuild b/app-misc/mtail/mtail-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..3dafa4bf2543
--- /dev/null
+++ b/app-misc/mtail/mtail-1.1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mtail/mtail-1.1.1-r1.ebuild,v 1.1 2003/12/26 18:29:08 taviso Exp $
+
+DESCRIPTION="tail workalike, that performs output colourising"
+HOMEPAGE="http://matt.immute.net/src/mtail/"
+SRC_URI="http://matt.immute.net/src/mtail/mtail-${PV}.tgz
+ http://matt.immute.net/src/mtail/mtailrc-syslog.sample"
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc"
+IUSE=""
+
+DEPEND=""
+
+RDEPEND="dev-lang/python"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${P}.tgz
+ cd ${S}; epatch ${FILESDIR}/${P}-remove-blanks.patch
+}
+
+src_install() {
+ dobin mtail
+ dodoc CHANGES LICENSE mtailrc.sample README ${DISTDIR}/mtailrc-syslog.sample
+}