summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-10-29 06:11:27 +0000
committerJoe McCann <joem@gentoo.org>2005-10-29 06:11:27 +0000
commitf4c7aa114dfc6e7febd069041a606630035ba008 (patch)
tree004da2f0135fecaa25b588d003fe82eda1de6d92 /app-office/gnumeric/gnumeric-1.6.0.ebuild
parentAdd preserve_old_lib function to deal with the so name change. This should fi... (diff)
downloadhistorical-f4c7aa114dfc6e7febd069041a606630035ba008.tar.gz
historical-f4c7aa114dfc6e7febd069041a606630035ba008.tar.bz2
historical-f4c7aa114dfc6e7febd069041a606630035ba008.zip
New version of gnumeric. Cleaned up ebuild, remove libgda support(requires dev version), and update deps. Removing other archs until goffice has the proper keywords. Closes bug #108969
Package-Manager: portage-2.0.53_rc6
Diffstat (limited to 'app-office/gnumeric/gnumeric-1.6.0.ebuild')
-rw-r--r--app-office/gnumeric/gnumeric-1.6.0.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/app-office/gnumeric/gnumeric-1.6.0.ebuild b/app-office/gnumeric/gnumeric-1.6.0.ebuild
new file mode 100644
index 000000000000..6af74a1d1084
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.6.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.6.0.ebuild,v 1.1 2005/10/29 06:11:26 joem Exp $
+
+inherit eutils flag-o-matic gnome2
+
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+HOMEPAGE="http://www.gnome.org/projects/gnumeric/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="gnome python static"
+# bonobo gnomedb libgda
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=gnome-extra/libgsf-1.13.2
+ >=x11-libs/goffice-0.1.0
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/libgnomeprint-2.8.2
+ >=gnome-base/libgnomeprintui-2.8.2
+ >=media-libs/libart_lgpl-2.3.11
+
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2
+ >=gnome-base/libbonoboui-2.2 )
+ python? (
+ >=dev-lang/python-2
+ >=dev-python/pygtk-2 )"
+ #libgda? ( >=gnome-extra/libgda-1.0.1 )
+# gnomedb? ( >=gnome-extra/libgnomedb-0.90.2 )
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.9
+ app-text/scrollkeeper"
+
+DOCS="AUTHORS COPYING* ChangeLog HACKING NEWS README TODO"
+USE_DESTDIR="1"
+
+
+pkg_setup() {
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ einfo "libgsf needs to be compiled with gnome in USE"
+ einfo "for this version of gnumeric to work. Rebuild"
+ einfo "libgsf first like this :"
+ einfo "USE=gnome emerge libgsf -vp"
+ die "libgsf was built without gnome support..."
+ fi
+ #gcc bug (http://bugs.gnome.org/show_bug.cgi?id=128834)
+ replace-flags "-Os" "-O2"
+}
+
+src_unpack() {
+ unpack "${A}"
+ gnome2_omf_fix
+ cd ${S}/doc/C
+ gnome2_omf_fix Makefile.in
+}
+
+G2CONF="${G2CONF} $(use_with python) $(use_with gnome) $(use_enable static) --enable-ssindex"
+
+src_install() {
+
+ gnome2_src_install
+
+ # make gnumeric find it's help
+ dosym \
+ /usr/share/gnome/help/gnumeric \
+ /usr/share/${PN}/${PV}/doc
+
+}