summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-27 23:44:43 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-27 23:44:43 +0000
commite993d290162b5937fb3457c17bd37e77341d2ab1 (patch)
tree54dc603bb2494eb476a5c2808413ef5b0dd11dab /app-office/kchart
parentlibsdl patch for new libcaca api (diff)
downloadhistorical-e993d290162b5937fb3457c17bd37e77341d2ab1.tar.gz
historical-e993d290162b5937fb3457c17bd37e77341d2ab1.tar.bz2
historical-e993d290162b5937fb3457c17bd37e77341d2ab1.zip
Version bump.
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'app-office/kchart')
-rw-r--r--app-office/kchart/ChangeLog7
-rw-r--r--app-office/kchart/files/digest-kchart-1.6_rc13
-rw-r--r--app-office/kchart/kchart-1.6_rc1.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/app-office/kchart/ChangeLog b/app-office/kchart/ChangeLog
index 5f50314cb9a1..0d381771cb0f 100644
--- a/app-office/kchart/ChangeLog
+++ b/app-office/kchart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kchart
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/ChangeLog,v 1.45 2006/09/15 18:41:47 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/ChangeLog,v 1.46 2006/09/27 23:40:39 carlo Exp $
+
+*kchart-1.6_rc1 (27 Sep 2006)
+
+ 27 Sep 2006; Carsten Lohrke <carlo@gentoo.org> +kchart-1.6_rc1.ebuild:
+ Version bump.
*kchart-1.6_beta1 (15 Sep 2006)
diff --git a/app-office/kchart/files/digest-kchart-1.6_rc1 b/app-office/kchart/files/digest-kchart-1.6_rc1
new file mode 100644
index 000000000000..22dfd6c9ed05
--- /dev/null
+++ b/app-office/kchart/files/digest-kchart-1.6_rc1
@@ -0,0 +1,3 @@
+MD5 2134a0d09a3f98b91a062c7bafb57622 koffice-1.5.92.tar.bz2 54676447
+RMD160 4006772a542c24132ef7b7d16ad087beb6eb76cd koffice-1.5.92.tar.bz2 54676447
+SHA256 a4df08decea688dddfeec7b47e0fb4e96bf75e1c85b72b721d315d718bae11c5 koffice-1.5.92.tar.bz2 54676447
diff --git a/app-office/kchart/kchart-1.6_rc1.ebuild b/app-office/kchart/kchart-1.6_rc1.ebuild
new file mode 100644
index 000000000000..cfbcb8c64e2e
--- /dev/null
+++ b/app-office/kchart/kchart-1.6_rc1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/kchart-1.6_rc1.ebuild,v 1.1 2006/09/27 23:40:39 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice integrated graph and chart drawing tool."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store
+ libkochart interfaces"
+
+KMEXTRACTONLY="lib/
+ interfaces/"
+
+KMEXTRA="filters/kchart"
+
+KMCOMPILEONLY="filters/libdialogfilter"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = libdialogfilter kchart" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}