summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-14 13:45:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-14 13:45:10 +0000
commit02753e7c984d3ee87772c73116dd33555b1d2814 (patch)
tree66387452fa14bd3d7c18038d47de4c763a894850 /app-office/lyx
parentppc stable wrt #344827, #354237 (diff)
downloadhistorical-02753e7c984d3ee87772c73116dd33555b1d2814.tar.gz
historical-02753e7c984d3ee87772c73116dd33555b1d2814.tar.bz2
historical-02753e7c984d3ee87772c73116dd33555b1d2814.zip
version bump, thanks Pavel
Package-Manager: portage-2.2.0_alpha23/cvs/Linux x86_64
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/ChangeLog7
-rw-r--r--app-office/lyx/lyx-1.6.9.ebuild164
2 files changed, 170 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index 40abcd13f882..e51c1249163e 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/lyx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.220 2011/01/09 17:09:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.221 2011/02/14 13:45:10 aballier Exp $
+
+*lyx-1.6.9 (14 Feb 2011)
+
+ 14 Feb 2011; Alexis Ballier <aballier@gentoo.org> +lyx-1.6.9.ebuild:
+ version bump, thanks Pavel
09 Jan 2011; Raúl Porcel <armin76@gentoo.org> lyx-1.6.8.ebuild:
alpha/ia64/sparc stable wrt #349516
diff --git a/app-office/lyx/lyx-1.6.9.ebuild b/app-office/lyx/lyx-1.6.9.ebuild
new file mode 100644
index 000000000000..fa787c32d904
--- /dev/null
+++ b/app-office/lyx/lyx-1.6.9.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.6.9.ebuild,v 1.1 2011/02/14 13:45:10 aballier Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+
+inherit qt4-r2 eutils flag-o-matic font python toolchain-funcs
+
+MY_P="${P/_}"
+
+S="${WORKDIR}/${MY_P}"
+FONT_S="${S}/lib/fonts"
+FONT_SUFFIX="ttf"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/${P}.tar.bz2"
+#SRC_URI="ftp://ftp.devel.lyx.org/pub/lyx/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cups debug nls latex monolithic-build html rtf dot docbook dia subversion rcs svg"
+
+LANGS="ar ca cs de el en es eu fi fr gl he hu id it ja nb nn pl pt ro ru sk tr uk zh_CN zh_TW"
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+COMMONDEPEND="x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libxml2
+ app-text/aiksaurus
+ virtual/aspell-dict
+ media-libs/fontconfig
+ media-libs/freetype
+ >=dev-libs/boost-1.34"
+
+RDEPEND="${COMMONDEPEND}
+ || ( dev-texlive/texlive-fontsextra app-text/ptex )
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick )
+ cups? ( virtual/lpr )
+ latex? (
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ app-text/noweb
+ dev-tex/dvipost
+ dev-tex/chktex
+ app-text/ps2eps
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-science
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ html? ( dev-tex/html2latex )
+ rtf? (
+ dev-tex/latex2rtf
+ app-text/unrtf
+ dev-tex/html2latex
+ )
+ linguas_he? ( dev-tex/culmus-latex )
+ docbook? ( app-text/sgmltools-lite )
+ dot? ( media-gfx/graphviz )
+ dia? ( app-office/dia )
+ subversion? ( dev-vcs/subversion )
+ rcs? ( dev-vcs/rcs )
+ svg? ( || ( gnome-base/librsvg media-gfx/inkscape ) )"
+
+DEPEND="${COMMONDEPEND}
+ x11-proto/xproto
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python_set_active_version 2
+ font_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/1.6.7-python.patch
+ echo "#!/bin/sh" > config/py-compile
+ sed "s:python -tt:$(PYTHON) -tt:g" -i lib/configure.py || die
+}
+
+src_configure() {
+ tc-export CXX
+ #bug 221921
+ export VARTEXFONTS=${T}/fonts
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_enable monolithic-build) \
+ --with-aspell --without-included-boost --disable-stdlib-debug
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ANNOUNCE NEWS README RELEASE-NOTES UPGRADING "${FONT_S}"/*.txt || die
+
+ if use linguas_he ; then
+ echo "\bind_file cua" > "${T}"/hebrew.bind
+ echo "\bind \"F12\" \"language hebrew\"" >> "${T}"/hebrew.bind
+
+ insinto /usr/share/lyx/bind
+ doins "${T}"/hebrew.bind || die
+ fi
+
+ doicon ${PN} "$S/development/Win32/packaging/icons/lyx_32x32.png"
+ make_desktop_entry ${PN} "LyX" "/usr/share/pixmaps/lyx_32x32.png" "Office"
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx || die
+ fi
+
+ # fonts needed for proper math display, see also bug #15629
+ font_src_install
+
+ python_convert_shebangs -r 2 "${D}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ # instructions for RTL support. See also bug 168331.
+ if use linguas_he || use linguas_ar; then
+ elog
+ elog "Enabling RTL support in LyX:"
+ elog "If you intend to use a RTL language (such as Hebrew or Arabic)"
+ elog "You must enable RTL support in LyX. To do so start LyX and go to"
+ elog "Tools->Preferences->Language settings->Language"
+ elog "and make sure the \"Right-to-left language support\" is checked"
+ elog
+ fi
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}