summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-08 20:33:39 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-08 20:33:39 +0000
commit030559008b9c3a68e94363738b9617374e9fb123 (patch)
treea78314b0890192ee0abc7f7b86555c4f9ca8f334 /app-office/openoffice-bin
parentStable on x86. Bug# 108333 (diff)
downloadhistorical-030559008b9c3a68e94363738b9617374e9fb123.tar.gz
historical-030559008b9c3a68e94363738b9617374e9fb123.tar.bz2
historical-030559008b9c3a68e94363738b9617374e9fb123.zip
multilib fixes
Package-Manager: portage-2.0.53_rc4
Diffstat (limited to 'app-office/openoffice-bin')
-rw-r--r--app-office/openoffice-bin/Manifest2
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild10
2 files changed, 8 insertions, 4 deletions
diff --git a/app-office/openoffice-bin/Manifest b/app-office/openoffice-bin/Manifest
index 8c633e68b2df..11dd35c536f1 100644
--- a/app-office/openoffice-bin/Manifest
+++ b/app-office/openoffice-bin/Manifest
@@ -13,4 +13,4 @@ MD5 b986cfdd8585ed8adde6bcff8f427361 openoffice-bin-1.1.1.ebuild 5857
MD5 d39203cfa3918278f573580eae65e184 openoffice-bin-1.1.4-r1.ebuild 5006
MD5 754b2a399f6c90c5a6f17d2efc30131d openoffice-bin-1.1.5.ebuild 4718
MD5 56d86f2c4d757bb5c28f53df6f32732f openoffice-bin-2.0.0_rc1.ebuild 6641
-MD5 f4ba34b1fab5a39ad485d3cb9bbed281 openoffice-bin-2.0.0_rc2.ebuild 6907
+MD5 b1f2ad8373b8ac38a8d2256066dc7160 openoffice-bin-2.0.0_rc2.ebuild 7065
diff --git a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild
index cdd1ba4f4468..9a4ace9e54ca 100644
--- a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild,v 1.2 2005/10/08 19:14:13 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0_rc2.ebuild,v 1.3 2005/10/08 20:33:39 suka Exp $
-inherit eutils fdo-mime rpm
+inherit eutils fdo-mime rpm multilib
IUSE="gnome java kde"
-INSTDIR="/usr/lib/openoffice"
MY_PV="${PV/_rc2/rc1}"
MY_PV2="${MY_PV}_050923"
MY_PV3="${PV/_rc2}"
@@ -121,6 +120,10 @@ src_unpack() {
src_install () {
+ #Multilib install dir magic for AMD64
+ has_multilib_profile && ABI=x86
+ INSTDIR="/usr/$(get_libdir)/openoffice"
+
einfo "Installing OpenOffice.org into build root..."
dodir ${INSTDIR}
dodir /usr/share/icons
@@ -144,6 +147,7 @@ src_install () {
# Install wrapper script
newbin ${FILESDIR}/${MY_PV3}/ooo-wrapper2 ooffice2
sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice2 || die
+ sed -i -e "s:lib/:$(get_libdir)/:" ${D}/usr/bin/ooffice2 || die
# Component symlinks
for app in base calc draw fromtemplate impress math web writer; do