summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-10-11 18:49:53 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-10-11 18:49:53 +0000
commit12c870c0db611b0b0f7c10d9465667e1ba2a66e8 (patch)
tree8a91b55d669644f0c8ca3253a5a9911c6bcc2a6d /app-office
parentMarked ~ppc-macos (bug #108462) (diff)
downloadhistorical-12c870c0db611b0b0f7c10d9465667e1ba2a66e8.tar.gz
historical-12c870c0db611b0b0f7c10d9465667e1ba2a66e8.tar.bz2
historical-12c870c0db611b0b0f7c10d9465667e1ba2a66e8.zip
more cleanups
Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-bin/Manifest5
-rw-r--r--app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3197
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-1.1.4-r12
-rw-r--r--app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc150
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.1.4-r1.ebuild171
-rw-r--r--app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild178
6 files changed, 0 insertions, 603 deletions
diff --git a/app-office/openoffice-bin/Manifest b/app-office/openoffice-bin/Manifest
index 49d422df94a2..f147e45c29ca 100644
--- a/app-office/openoffice-bin/Manifest
+++ b/app-office/openoffice-bin/Manifest
@@ -1,13 +1,8 @@
MD5 ce67e1757e963ef64c615b4454f92cc3 ChangeLog 18335
-MD5 4045e7a45d5209ff0ac93c5c5db0114b files/1.1.4/ooffice-wrapper-1.3 6659
MD5 475dbfca78a66962143b39d3aac7915a files/1.1.5/ooffice-wrapper-1.3 6659
MD5 2919847c6afebe7fd157c48e78fb5770 files/2.0.0/ooo-wrapper2 3703
-MD5 753fd14ec632a7fe71ab9abef357f93f files/digest-openoffice-bin-1.1.4-r1 141
MD5 5828bbd9e0139dae2ff43c23a65a844b files/digest-openoffice-bin-1.1.5 82
-MD5 e03d40bf3ce0e7ed62819425202e5849 files/digest-openoffice-bin-2.0.0_rc1 4647
MD5 3b06710458e6c9459598c42fd08598e7 files/digest-openoffice-bin-2.0.0_rc2 4647
MD5 7134ec08f56019fc5db7f3e84acea4df metadata.xml 460
-MD5 d39203cfa3918278f573580eae65e184 openoffice-bin-1.1.4-r1.ebuild 5006
MD5 754b2a399f6c90c5a6f17d2efc30131d openoffice-bin-1.1.5.ebuild 4718
-MD5 32bfa1358e928e738749074b69cf01f0 openoffice-bin-2.0.0_rc1.ebuild 6665
MD5 daaa631b7b541ce6581f5b8aecae7aa1 openoffice-bin-2.0.0_rc2.ebuild 7071
diff --git a/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3 b/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3
deleted file mode 100644
index c12d92e91bd1..000000000000
--- a/app-office/openoffice-bin/files/1.1.4/ooffice-wrapper-1.3
+++ /dev/null
@@ -1,197 +0,0 @@
-#!/bin/sh
-#
-# Wrapper script for openoffice
-#
-# (C) Peter 'Nidd' Novodvorsky, 2001,2002
-# (C) Martin 'empty' Quinson, 2002.
-# Modifications by Chris Halls
-# Modifications by Lucien Saviot
-
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-
-# this string should be exactly as in ~/.sversionrc
-PV=<pv>
-OOVERSION="OpenOffice.org ${PV}"
-
-##
-## Source system configuration file
-##
-[ -r /etc/openoffice/openoffice.conf ] && . /etc/openoffice/openoffice.conf
-
-# Migration to new user install dir
-if [ -d "$HOME/.openoffice/1.1.3" ] ; then
- mv $HOME/.openoffice/1.1.3 $HOME/.openoffice/1.1.4
- sed -i -e s/'.openoffice\/1.1.3'/'.openoffice\/1.1.4'/g $HOME/.sversionrc
- sed -i -e s/1.1.3/1.1.4/g $HOME/.openoffice/1.1.4/user/basic/*.xlc
- echo "Your user install dir has been moved over to the new version"
-fi
-
-#Make smooth up- and downgrading between minor versions possible
-if [ -e "$HOME/.sversionrc" ] ; then
- sed -i -e s/1.1.3/1.1.4/g $HOME/.sversionrc
-fi
-
-if [ ! -f "/proc/version" ] ; then
- echo "--- Warning - OO.o will not work without a mounted /proc filesystem ---"
-fi
-
-###
-### Get user settings directory from ~/.sversionrc and echo directory name to stdout
-### get_settings_dir <Version>
-### return: 0 - directory found,
-### 1 - ~/.sversionrc non existent
-### 2 - entry exists in ~/.sversionrc but directory not found
-### 3 - ~/.sversionrc exists but no entry found
-get_settings_dir()
-{
- [ -r ${HOME}/.sversionrc ] || exit 1
- # warning, .sversionrc is DOS encoded so strip ^M
- settings_dir="`tr -d '\r' < ~/.sversionrc | sed -n "/^$1=/s%^$1=file://\(.*\)$%\1%p"`"
- echo "$settings_dir"
- [ -n "$settings_dir" ] || exit 3
- [ -d "$settings_dir" ] || exit 2
-}
-
-##
-## where does OO live for this user ?
-##
-OOHOME="`get_settings_dir "$OOVERSION"`"
-if [ $? -eq 2 ] ; then
- # .sversionrc contains a version yet the directory does not exist
- echo "I'm confused because I can't find OpenOffice's user files."
- echo "Your ~/.sversionrc file tells they should be under $OOHOME,"
- echo "but they are not. Please fix the situation manually."
- echo "You may want to edit ~/.sversionrc to indicate where is OO"
- echo "installed, or remove it if you did remove your installation"
- echo "directory manually (you bad one)."
- exit 1
-fi
-
-##
-## Add /usr/share/fonts to font search path
-##
-
-# Default font path. This is used if SAL_FONTPATH_PRIVATE is not defined.
-
-GENTOO_FONTPATH=""
-for d in `find /usr/share/fonts -maxdepth 1 -mindepth 1 -type d` ; do
- GENTOO_FONTPATH="$GENTOO_FONTPATH;$d"
-done
-
-SAL_FONTPATH_PRIVATE=${SAL_FONTPATH_PRIVATE:-"$GENTOO_FONTPATH"}
-export SAL_FONTPATH_PRIVATE
-
-## search LOCALE
-if [ -n "$LC_ALL" ]; then
- LOCALE="$LC_ALL"
- # OOo doesn't understand LC_ALL, so set LANG
- LANG="$LC_ALL"
-elif [ -n "$LANG" ]; then
- LOCALE="$LANG"
-elif [ -n "$LC_MESSAGES" ]; then
- LOCALE="$LC_MESSAGES"
- LANG="$LC_MESSAGES"
-else
- LOCALE="en_US"
-fi
-
-# Set locale to en_US if locale is C
-if [ "x$LOCALE" = "xC" ] ; then LOCALE="en_US"; fi
-
-LOCALEOO=`echo $LOCALE | sed 's/_/-/'`
-
-##
-## install OO for this user if needed
-##
-if [ -z "$OOHOME" ] ; then
- if [ -e /etc/openoffice/autoresponse-<pv>.conf ] && \
- grep -q DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf ; then
-
- # first install
- OOHOME=`grep DESTINATIONPATH /etc/openoffice/autoresponse-<pv>.conf | \
- sed -e 's/DESTINATIONPATH=//' -e "s|<home>|$HOME|"`
-
- if [ -d "$OOHOME" ]; then
- echo "openoffice.org: You have no entry for $OOVERSION in ~/.sversionrc, "
- echo "yet the directory $OOHOME exists."
- echo "Please remove $OOHOME and try again."
- exit 1
- fi
-
- echo "running openoffice.org setup..."
- if ! /opt/OpenOffice.org/program/setup -R:/etc/openoffice/autoresponse-<pv>.conf >& /dev/null; then
- echo "setup failed.. abort"
- exit 1
- fi
-
- echo "Setup complete. Running openoffice.org..."
-
-else
- echo "openoffice.org: Damnit! I can't find OpenOffice's user files. Did you break"
- echo "the /etc/openoffice/autoresponse-<pv>.conf file manually ?"
- echo "This file should contain DESTINATIONPATH"
- exit 1
- fi
-fi
-
-##
-## If no file is specified on the command line, which application to start?
-## The wrapper can be called from several links in /usr/bin
-##
-if [ $# = 0 ]; then
- case `basename $0` in
- oocalc) set -- private:factory/scalc;;
- oodraw) set -- private:factory/sdraw;;
- ooimpress) set -- private:factory/simpress;;
- oomath) set -- private:factory/smath;;
- ooweb) set -- private:factory/swriter/web;;
- oowriter) set -- private:factory/swriter;;
- oomaster) set -- private:factory/swriter/Global;;
- esac
-fi
-
-## Previous dead installation?
-[ -d $HOME/.openoffice/user ] && echo "Warning: you have a user settings directory from 1.0.0 in ~/.openoffice/user - this is no longer used"
-
-# Check whether the programs actually link to anything, or are from an old
-# version.
-
-if [ ! -s $OOHOME/setup ]; then
- echo "${OOHOME}/setup links to nothing, resetting link"
- ln -sf /opt/OpenOffice.org/program/setup ${OOHOME}/setup
-fi
-if [ ! -s $OOHOME/soffice ]; then
- echo "${OOHOME}/soffice links to nothing, resetting link"
- ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/soffice
-fi
-if [ ! -s $OOHOME/spadmin ]; then
- echo "${OOHOME}/spadmin links to nothing, resetting link"
- ln -sf /opt/OpenOffice.org/program/soffice ${OOHOME}/spadmin
-fi
-
-
-##
-## That's it. Launch the beast (with the given args)
-##
-LANG=$LOCALE
-export LANG
-case `basename $0` in
- oosetup) exec "$OOHOME/setup"
- ;;
- oopadmin) exec "$OOHOME/spadmin"
- ;;
- *) exec "$OOHOME/soffice" "$@"
- ;;
-esac
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.4-r1 b/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.4-r1
deleted file mode 100644
index ccd91efa015b..000000000000
--- a/app-office/openoffice-bin/files/digest-openoffice-bin-1.1.4-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 cf2d0beb6cae98acae81e4d690d63094 OOo_1.1.4_LinuxIntel_install.tar.gz 80144225
-MD5 c8155fbc898e76d46a1e1177c3e9666b libsot645li.so 305472
diff --git a/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc1 b/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc1
deleted file mode 100644
index eb108c6f8957..000000000000
--- a/app-office/openoffice-bin/files/digest-openoffice-bin-2.0.0_rc1
+++ /dev/null
@@ -1,50 +0,0 @@
-MD5 38f4348297235cc2d7425d5ea6011db3 OOo_2.0.0rc1_050923_LinuxIntel_install.tar.gz 106462692
-MD5 e6f37c57e284e8475db9b02c98852b59 openoffice.org-af-2.0.0-1.i586.tar.gz 13328420
-MD5 6c3e880197c7793faf4e8ed4dc2b3c3e OOo_2.0.0rc1_050923_LinuxIntel_langpack_be-BY.tar.gz 13371433
-MD5 6ecd6054de577d32436837fc6d542b2c OOo_2.0.0rc1_050923_LinuxIntel_langpack_bg.tar.gz 13899142
-MD5 cd03e742252bc59d1d600510b0c9e4e0 openoffice.org-bn-2.0.0-1.i586.tar.gz 13242027
-MD5 eba9cbf34653f1624a1a30c63ad4eda1 openoffice.org-br-2.0.0-1.i586.tar.gz 14301022
-MD5 4e54babd2a958a993a900cc7ec08fb93 OOo_2.0.0rc1_050923_LinuxIntel_langpack_ca.tar.gz 13326360
-MD5 64d1c2a7b793de414004b5edf1881203 OOo_2.0.0rc1_050923_LinuxIntel_langpack_cs.tar.gz 13974698
-MD5 0a5dd5a82da6b1c3107979e4fef6f553 OOo_2.0.0rc1_050923_LinuxIntel_langpack_cy.tar.gz 13249147
-MD5 00b0c1cbf68b7070b0c2b8845dc3de92 OOo_2.0.0rc1_050923_LinuxIntel_langpack_da.tar.gz 13852353
-MD5 b0818aa40b4c06a7514d51347d4a0ab5 OOo_2.0.0rc1_050923_LinuxIntel_langpack_de.tar.gz 14806485
-MD5 94c0b4067daec5996241ac22b6e67cfa OOo_2.0.0rc1_050923_LinuxIntel_langpack_el.tar.gz 13375924
-MD5 973c9bb8140b08c332b346a5d7b22af3 openoffice.org-en-GB-2.0.0-1.i586.tar.gz 13382609
-MD5 ac60895eab133503c64f5b32497cfaae OOo_2.0.0rc1_050923_LinuxIntel_langpack_es.tar.gz 14121988
-MD5 ddf0d446e42e03ccf4a6084da4b76a36 OOo_2.0.0rc1_050923_LinuxIntel_langpack_et.tar.gz 14047064
-MD5 e326c4440eb024357e3f8347337aeba2 OOo_2.0.0rc1_050923_LinuxIntel_langpack_fi.tar.gz 13353046
-MD5 60b949bbadec2730923940af9e599ffb OOo_2.0.0rc1_050923_LinuxIntel_langpack_fr.tar.gz 14324365
-MD5 368325b6a0da0f22bccb6565f87f3cf1 openoffice.org-ga-2.0.0-1.i586.tar.gz 13530732
-MD5 47461ca1064333d23105e2d16b9eb3ef OOo_2.0.0rc1_050923_LinuxIntel_langpack_gu-IN.tar.gz 13385309
-MD5 f60bd617d56ef7df7376e76418426071 OOo_2.0.0rc1_050923_LinuxIntel_langpack_hr.tar.gz 13620209
-MD5 aad87a7c16eb6391a83236901e0dda14 OOo_2.0.0rc1_050923_LinuxIntel_langpack_hu.tar.gz 13429807
-MD5 a9dfe066c20188e6af3407834bac9dfb OOo_2.0.0rc1_050923_LinuxIntel_langpack_it.tar.gz 14096662
-MD5 36caebadf9189e573892f37ffa61ed2f OOo_2.0.0rc1_050923_LinuxIntel_langpack_ja.tar.gz 14868104
-MD5 0215c25b119cf372751fec562358c089 OOo_2.0.0rc1_050923_LinuxIntel_langpack_km.tar.gz 16711713
-MD5 bd0b7eca6ae543a98079969ce5f4ac5f OOo_2.0.0rc1_050923_LinuxIntel_langpack_ko.tar.gz 14008179
-MD5 b04a6cebc8e2d3f04b04dadebc278029 openoffice.org-lt-2.0.0-1.i586.tar.gz 13287300
-MD5 c7e578ad4b4aa8c57216191059edc275 openoffice.org-lv-2.0.0-1.i586.tar.gz 13270491
-MD5 d4063f87e898d1e4d2bbc3763ddcb92e openoffice.org-mk-2.0.0-1.i586.tar.gz 13973252
-MD5 0e8ddb9239534c69b7fc6156a7b7a165 openoffice.org-nb-2.0.0-1.i586.tar.gz 13293930
-MD5 cc6c912df11be63176063e2f01f67323 openoffice.org-ne-2.0.0-1.i586.tar.gz 13317544
-MD5 fe935a1f29710d9bf4f4ececca57201f OOo_2.0.0rc1_050923_LinuxIntel_langpack_nl.tar.gz 14406061
-MD5 e1cd6ab761f11f7688fb5df193b22f0d OOo_2.0.0rc1_050923_LinuxIntel_langpack_nn.tar.gz 13308096
-MD5 55355175f3af340d97302f4debc2c113 openoffice.org-ns-2.0.0-1.i586.tar.gz 13237332
-MD5 a2fd6f64efab65489447de19386b4091 OOo_2.0.0rc1_050923_LinuxIntel_langpack_pa-IN.tar.gz 13365518
-MD5 c4732b4cbec6b15b8200522ccd9e4549 OOo_2.0.0rc1_050923_LinuxIntel_langpack_pl.tar.gz 13631266
-MD5 cb0a2dd29bd62de7bee9290b5245d3c4 OOo_2.0.0rc1_050923_LinuxIntel_langpack_pt-BR.tar.gz 14097342
-MD5 c9c1b86c39a05b8a6d5a02072cb0eda4 OOo_2.0.0rc1_050923_LinuxIntel_langpack_rw.tar.gz 13637070
-MD5 3df83588edf624358090aafc9c6132b6 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sh-YU.tar.gz 13323973
-MD5 37e65affa5d9f0c98712b048a7e47ec6 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sk.tar.gz 13871200
-MD5 23ff0960425a0da58f2bc238ad026fd2 openoffice.org-sl-2.0.0-1.i586.tar.gz 13249901
-MD5 7489e2ba4957e8792c8fb682a6c2501b OOo_2.0.0rc1_050923_LinuxIntel_langpack_sr-CS.tar.gz 13404311
-MD5 33254d107f842dc7cf6cf85ae3694870 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sv.tar.gz 13905099
-MD5 fbd31c5e56202974c3106db9680de043 OOo_2.0.0rc1_050923_LinuxIntel_langpack_sw-TZ.tar.gz 13468609
-MD5 76fc32da7092fb95660f3cb37160f614 openoffice.org-tn-2.0.0-1.i586.tar.gz 13334979
-MD5 e79a9e7567bcf670113e316a038096bb OOo_2.0.0rc1_050923_LinuxIntel_langpack_tr.tar.gz 13489604
-MD5 d9e081b22918eb7fb1a2878d52058bc4 OOo_2.0.0rc1_050923_LinuxIntel_langpack_vi.tar.gz 13323686
-MD5 1ead8d57dd7b57b633a6f2b09fd06bb5 openoffice.org-xh-2.0.0-1.i586.tar.gz 13372865
-MD5 f224bead1a4f4cca69eeea586e6ae984 OOo_2.0.0rc1_050923_LinuxIntel_langpack_zh-CN.tar.gz 14184088
-MD5 0466fe6584e430a2f459a8e507b25c25 OOo_2.0.0rc1_050923_LinuxIntel_langpack_zh-TW.tar.gz 14353708
-MD5 be18b45d7b3dac54941595d3e25de6a3 openoffice.org-zu-2.0.0-1.i586.tar.gz 13294891
diff --git a/app-office/openoffice-bin/openoffice-bin-1.1.4-r1.ebuild b/app-office/openoffice-bin/openoffice-bin-1.1.4-r1.ebuild
deleted file mode 100644
index c3afd53fae59..000000000000
--- a/app-office/openoffice-bin/openoffice-bin-1.1.4-r1.ebuild
+++ /dev/null
@@ -1,171 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.1.4-r1.ebuild,v 1.5 2005/08/23 21:16:04 suka Exp $
-
-# NOTE: There are two big issues that should be addressed.
-#
-# 1) Language support and fonts should be addressed.
-
-inherit eutils fdo-mime
-
-IUSE="java kde"
-
-INSTDIR="/opt/OpenOffice.org"
-MY_P="OOo_${PV}_LinuxIntel_install"
-
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="OpenOffice productivity suite"
-
-SRC_URI="x86? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )
- amd64? ( mirror://openoffice/stable/${PV}/OOo_${PV}_LinuxIntel_install.tar.gz )
- mirror://openoffice/contrib/rc/1.1.4secpatch/libsot645li.so"
-
-HOMEPAGE="http://www.openoffice.org/"
-
-LICENSE="|| ( LGPL-2 SISSL-1.1 )"
-SLOT="0"
-KEYWORDS="x86 amd64"
-
-RDEPEND="!app-office/openoffice
- virtual/x11
- virtual/libc
- >=dev-lang/perl-5.0
- app-arch/zip
- app-arch/unzip
- java? ( >=virtual/jre-1.4.1 )
- amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )"
-
-DEPEND="${RDEPEND}
- sys-apps/findutils"
-
-PROVIDE="virtual/ooo"
-
-src_install() {
- # Sandbox issues; bug #8587
- addpredict "/user"
- addpredict "/share"
- addpredict "/dev/dri"
- addpredict "/usr/bin/soffice"
- addpredict "/pspfontcache"
- addpredict "/root/.gconfd"
- addpredict "/opt/OpenOffice.org/foo.tmp"
- addpredict "/opt/OpenOffice.org/delme"
-
- # Autoresponse file for main installation
- cat > ${T}/rsfile-global <<-"END_RS"
- [ENVIRONMENT]
- INSTALLATIONMODE=INSTALL_NETWORK
- INSTALLATIONTYPE=STANDARD
- DESTINATIONPATH=<destdir>
- OUTERPATH=
- LOGFILE=
- LANGUAGELIST=<LANGUAGE>
-
- [JAVA]
- JavaSupport=preinstalled_or_none
- END_RS
-
- # Autoresponse file for user installation
- cat > ${T}/rsfile-local <<-"END_RS"
- [ENVIRONMENT]
- INSTALLATIONMODE=INSTALL_WORKSTATION
- INSTALLATIONTYPE=WORKSTATION
- DESTINATIONPATH=<home>/.openoffice/<pv>
-
- [JAVA]
- JavaSupport=none
- END_RS
-
- # Fixing install location in response file
- sed -e "s|<destdir>|${D}${INSTDIR}|" \
- ${T}/rsfile-global > ${T}/autoresponse || die
-
- einfo "Installing OpenOffice.org into build root..."
- dodir ${INSTDIR}
- cd ${S}
- ./setup -v -noexit -nogui -r:${T}/autoresponse || die "Setup failed"
-
- einfo "Removing build root from registry..."
- # Remove totally useless stuff.
- rm -f ${D}${INSTDIR}/program/{setup.log,sopatchlevel.sh} || die
- # Remove build root from registry and co
- egrep -rl "${D}" ${D}${INSTDIR}/* | \
- xargs -i perl -pi -e "s|${D}||g" {} || :
-
- einfo "Fixing permissions..."
- # Fix permissions
- find ${D}${INSTDIR}/ -type f -exec chmod a+r {} \;
- chmod a+x ${D}${INSTDIR}/share/config/webcast/*.pl
-
- # Install user autoresponse file
- insinto /etc/openoffice
- sed -e "s|<pv>|${PV}|g" ${T}/rsfile-local > ${T}/autoresponse-${PV}.conf
- doins ${T}/autoresponse-${PV}.conf
-
- # Install wrapper script
- exeinto /usr/bin
- sed -e "s|<pv>|${PV}|g" \
- ${FILESDIR}/${PV}/ooffice-wrapper-1.3 > ${T}/ooffice
- doexe ${T}/ooffice
-
- # Component symlinks
- for app in calc draw impress math writer web setup padmin; do
- dosym ooffice /usr/bin/oo${app}
- done
-
- einfo "Installing menu shortcuts..."
- dodir /usr/share
- cp -pPR ${D}${INSTDIR}/share/kde/net/share/icons ${D}/usr/share
-
- use kde && cp -pPR ${D}${INSTDIR}/share/kde/net/share/mimelnk ${D}/usr/share
-
- for x in ${D}${INSTDIR}/share/kde/net/*.desktop; do
- # We have to handle soffice and setup differently
- sed -i -e "s:${INSTDIR}/program/setup:/usr/bin/oosetup:g" ${x}
- sed -i -e "s:${INSTDIR}/program/soffice:/usr/bin/ooffice:g" ${x}
- # Now fix the rest
- sed -i -e "s:${INSTDIR}/program/s:/usr/bin/oo:g" ${x}
- echo "Categories=Application;Office;" >> ${x}
- domenu ${x}
- rm ${x}
- done
-
- # Remove unneeded stuff
- rm -rf ${D}${INSTDIR}/share/cde || die
-
- # Fix instdb.ins, to *not* install local copies of these
- for entry in Kdeapplnk Kdemimetext Kdeicons Gnome_Apps Gnome_Icons Gnome2_Apps; do
- perl -pi -e "/^File gid_File_Extra_$entry/ .. /^End/ and (\
- s|^\tSize\s+\= .*|\tSize\t\t = 0;\r| or \
- s|^\tArchiveFiles\s+\= .*|\tArchiveFiles\t = 0;\r| or \
- s|^\tArchiveSize\s+\= .*|\tArchiveSize\t = 0;\r| or \
- s|^\tContains\s+\= .*|\tContains\t = ();\r| or \
- s|\t\t\t\t\t\".*|\r|g)" \
- ${D}${INSTDIR}/program/instdb.ins
- done
-
- # Make sure these do not get nuked.
- keepdir ${INSTDIR}/user/registry/res/en-us/org/openoffice/{Office,ucb} ${INSTDIR}/user/psprint/{driver,fontmetric} ${INSTDIR}/user/{autocorr,backup,plugin,store,temp,template}
-
- #touch files to make portage uninstalling happy (#22593)
- find ${D} -type f -exec touch {} \;
-
- # Security fix (#88863)
- rm -f ${D}${INSTDIR}/program/libsot645li.so || die
- cp -f ${DISTDIR}/libsot645li.so ${D}${INSTDIR}/program/ || die
-}
-
-pkg_postinst() {
-
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-
- einfo " To start OpenOffice.org, run:"
- einfo
- einfo " $ ooffice"
- einfo
- einfo " Also, for individual components, you can use any of:"
- einfo
- einfo " oocalc, oodraw, ooimpress, oomath, ooweb or oowriter"
-}
-
diff --git a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild b/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild
deleted file mode 100644
index 049e4a80d1bc..000000000000
--- a/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-2.0.0_rc1.ebuild,v 1.3 2005/10/08 20:50:28 blubb Exp $
-
-inherit eutils fdo-mime rpm multilib
-
-has_multilib_profile && ABI=x86
-
-IUSE="gnome java kde"
-
-INSTDIR="/usr/$(get_libdir)/openoffice"
-MY_PV="${PV/_}"
-MY_PV2="${MY_PV}_050923"
-MY_PV3="${PV/_rc1}"
-S="${WORKDIR}/OOO680_m1_native_packed-5_en-US.8958/RPMS"
-DESCRIPTION="OpenOffice productivity suite"
-
-LANGPACK="OOo_${MY_PV2}_LinuxIntel_langpack"
-LANGPACKPATH="http://oootranslation.services.openoffice.org/pub/OpenOffice.org/${MY_PV}/${LANGPACK}"
-LANGLOC="http://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/OOO680_m1/Build-1/OOo_OOO680_m1_native_LinuxIntel_langpacks_rpm"
-LANGSUFFIX="${MY_PV3}-1.i586.tar.gz"
-
-SRC_URI="mirror://openoffice/contrib/rc/${MY_PV}/OOo_${MY_PV2}_LinuxIntel_install.tar.gz
- linguas_af? ( ${LANGLOC}/openoffice.org-af-${LANGSUFFIX} )
- linguas_be_BY? ( ${LANGPACKPATH}_be-BY.tar.gz )
- linguas_bg? ( ${LANGPACKPATH}_bg.tar.gz )
- linguas_bn? ( ${LANGLOC}/openoffice.org-bn-${LANGSUFFIX} )
- linguas_br? ( ${LANGLOC}/openoffice.org-br-${LANGSUFFIX} )
- linguas_ca? ( ${LANGPACKPATH}_ca.tar.gz )
- linguas_cs? ( ${LANGPACKPATH}_cs.tar.gz )
- linguas_cy? ( ${LANGPACKPATH}_cy.tar.gz )
- linguas_da? ( ${LANGPACKPATH}_da.tar.gz )
- linguas_de? ( ${LANGPACKPATH}_de.tar.gz )
- linguas_el? ( ${LANGPACKPATH}_el.tar.gz )
- linguas_en_GB? ( ${LANGLOC}/openoffice.org-en-GB-${LANGSUFFIX} )
- linguas_es? ( ${LANGPACKPATH}_es.tar.gz )
- linguas_et? ( ${LANGPACKPATH}_et.tar.gz )
- linguas_fi? ( ${LANGPACKPATH}_fi.tar.gz )
- linguas_fr? ( ${LANGPACKPATH}_fr.tar.gz )
- linguas_ga? ( ${LANGLOC}/openoffice.org-ga-${LANGSUFFIX} )
- linguas_gu_IN? ( ${LANGPACKPATH}_gu-IN.tar.gz )
- linguas_hr? ( ${LANGPACKPATH}_hr.tar.gz )
- linguas_hu? ( ${LANGPACKPATH}_hu.tar.gz )
- linguas_it? ( ${LANGPACKPATH}_it.tar.gz )
- linguas_ja? ( ${LANGPACKPATH}_ja.tar.gz )
- linguas_km? ( ${LANGPACKPATH}_km.tar.gz )
- linguas_ko? ( ${LANGPACKPATH}_ko.tar.gz )
- linguas_lt? ( ${LANGLOC}/openoffice.org-lt-${LANGSUFFIX} )
- linguas_lv? ( ${LANGLOC}/openoffice.org-lv-${LANGSUFFIX} )
- linguas_mk? ( ${LANGLOC}/openoffice.org-mk-${LANGSUFFIX} )
- linguas_nb? ( ${LANGLOC}/openoffice.org-nb-${LANGSUFFIX} )
- linguas_ne? ( ${LANGLOC}/openoffice.org-ne-${LANGSUFFIX} )
- linguas_nl? ( ${LANGPACKPATH}_nl.tar.gz )
- linguas_nn? ( ${LANGPACKPATH}_nn.tar.gz )
- linguas_ns? ( ${LANGLOC}/openoffice.org-ns-${LANGSUFFIX} )
- linguas_pa_IN? ( ${LANGPACKPATH}_pa-IN.tar.gz )
- linguas_pl? ( ${LANGPACKPATH}_pl.tar.gz )
- linguas_pt_BR? ( ${LANGPACKPATH}_pt-BR.tar.gz )
- linguas_rw? ( ${LANGPACKPATH}_rw.tar.gz )
- linguas_sh_YU? ( ${LANGPACKPATH}_sh-YU.tar.gz )
- linguas_sk? ( ${LANGPACKPATH}_sk.tar.gz )
- linguas_sl? ( ${LANGLOC}/openoffice.org-sl-${LANGSUFFIX} )
- linguas_sr_CS? ( ${LANGPACKPATH}_sr-CS.tar.gz )
- linguas_sv? ( ${LANGPACKPATH}_sv.tar.gz )
- linguas_sw_TZ? ( ${LANGPACKPATH}_sw-TZ.tar.gz )
- linguas_tn? ( ${LANGLOC}/openoffice.org-tn-${LANGSUFFIX} )
- linguas_tr? ( ${LANGPACKPATH}_tr.tar.gz )
- linguas_vi? ( ${LANGPACKPATH}_vi.tar.gz )
- linguas_xh? ( ${LANGLOC}/openoffice.org-xh-${LANGSUFFIX} )
- linguas_zh_CN? ( ${LANGPACKPATH}_zh-CN.tar.gz )
- linguas_zh_TW? ( ${LANGPACKPATH}_zh-TW.tar.gz )
- linguas_zu? ( ${LANGLOC}/openoffice.org-zu-${LANGSUFFIX} )"
-
-HOMEPAGE="http://www.openoffice.org/"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-
-RDEPEND="!app-office/openoffice
- virtual/x11
- virtual/libc
- >=dev-lang/perl-5.0
- app-arch/zip
- app-arch/unzip
- java? ( >=virtual/jre-1.4.1 )
- amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.0 )
- linguas_ja? ( >=media-fonts/kochi-substitute-20030809-r3 )
- linguas_zh_CN? ( >=media-fonts/arphicfonts-0.1-r2 )
- linguas_zh_TW? ( >=media-fonts/arphicfonts-0.1-r2 )"
-
-DEPEND="${RDEPEND}
- sys-apps/findutils"
-
-PROVIDE="virtual/ooo"
-
-src_unpack() {
-
- unpack ${A}
-
- for i in base calc core01 core02 core03 core03u core04 core04u core05 core05u core06 core07 core08 core09 core10 draw impress math writer graphicfilter pyuno spellcheck testtool xsltfilter ; do
- rpm_unpack ${S}/openoffice.org-${i}-${MY_PV3}-1.i586.rpm
- done
-
- rpm_unpack ${S}/desktop-integration/openoffice.org-freedesktop-menus-${MY_PV3}-1.noarch.rpm
- use kde && rpm_unpack ${S}/desktop-integration/openoffice.org-suse-menus-${MY_PV3}-1.noarch.rpm
-
- use gnome && rpm_unpack ${S}/openoffice.org-gnome-integration-${MY_PV3}-1.i586.rpm
- use java && rpm_unpack ${S}/openoffice.org-javafilter-${MY_PV3}-1.i586.rpm
-
- strip-linguas en af be_BY bg bn br ca cs cy da de el en_GB es et fi fr ga gu_IN hr hu it ja km ko lt lv mk nb ne nl nn ns pa_IN pl pt_BR rw sh_YU sk sl sr_CS sv sw_TZ tn tr vi xh zh_CN zh_TW zu
-
- for i in ${LINGUAS}; do
- i="${i/_/-}"
- if [ ${i} != "en" ] ; then
- rpm_unpack openoffice.org-${i}-${MY_PV3}-1.i586.rpm
- rpm_unpack openoffice.org-${i}-help-${MY_PV3}-1.i586.rpm
- rpm_unpack openoffice.org-${i}-res-${MY_PV3}-1.i586.rpm
- fi
- done
-
-}
-
-src_install () {
-
- einfo "Installing OpenOffice.org into build root..."
- dodir ${INSTDIR}
- dodir /usr/share/icons
- dodir /usr/share/mime
- mv ${WORKDIR}/opt/openoffice.org2.0/* ${D}${INSTDIR}
- mv ${WORKDIR}/usr/share/icons/* ${D}/usr/share/icons
-
- use kde && dodir /usr/share/mimelnk/application && mv ${WORKDIR}/opt/kde3/share/mimelnk/application/* ${D}/usr/share/mimelnk/application
-
- #Menu entries
- cd ${D}${INSTDIR}/share/xdg/
-
- sed -i -e s/'Exec=openoffice.org-2.0-printeradmin'/'Exec=oopadmin2'/g printeradmin.desktop || die
-
- for desk in base calc draw impress math writer printeradmin; do
- mv ${desk}.desktop openoffice.org-2.0-${desk}.desktop
- sed -i -e s/openoffice.org-2.0/ooffice2/g openoffice.org-2.0-${desk}.desktop || die
- domenu openoffice.org-2.0-${desk}.desktop
- done
-
- # Install wrapper script
- newbin ${FILESDIR}/${MY_PV3}/ooo-wrapper2 ooffice2
- sed -i -e s/PV/${PV}/g ${D}/usr/bin/ooffice2 || die
- sed -i -e "s:lib/:$(get_libdir)/:" ${D}/usr/bin/ooffice2 || die
-
- # Component symlinks
- for app in base calc draw fromtemplate impress math web writer; do
- dosym ooffice2 /usr/bin/oo${app}2
- done
-
- dosym ${INSTDIR}/program/spadmin.bin /usr/bin/oopadmin2
-
- # Fixing some icon dir permissions
- chmod +r -R ${D}/usr/share/icons/ || die
-
- # Non-java weirdness see bug #99366
- use java || rm -f ${D}${INSTDIR}/program/javaldx
-}
-
-pkg_postinst() {
-
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-
- einfo " To start OpenOffice.org, run:"
- einfo
- einfo " $ ooffice2"
- einfo
- einfo " Also, for individual components, you can use any of:"
- einfo
- einfo " oobase2, oocalc2, oodraw2, oofromtemplate2, ooimpress2, oomath2,"
- einfo " ooweb2 or oowriter2"
-}