summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-11 16:37:27 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-11 16:37:27 +0000
commitccd3fa342198720daf6b3a18ec4d90b99d4c4a16 (patch)
treef0fc2a906759c440e53212e3e2f475692229e6b4 /app-office
parentAdded 1Q-2007 and moved the moves of slib, gauche and guile to it from 4Q-2006 (diff)
downloadhistorical-ccd3fa342198720daf6b3a18ec4d90b99d4c4a16.tar.gz
historical-ccd3fa342198720daf6b3a18ec4d90b99d4c4a16.tar.bz2
historical-ccd3fa342198720daf6b3a18ec4d90b99d4c4a16.zip
Drop old, version bump, fix bugs 159236, 148990
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'app-office')
-rw-r--r--app-office/mozilla-sunbird-bin/ChangeLog10
-rw-r--r--app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.33
-rw-r--r--app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3.ebuild77
3 files changed, 89 insertions, 1 deletions
diff --git a/app-office/mozilla-sunbird-bin/ChangeLog b/app-office/mozilla-sunbird-bin/ChangeLog
index 2b7d4a6ceee4..0c667f7198d7 100644
--- a/app-office/mozilla-sunbird-bin/ChangeLog
+++ b/app-office/mozilla-sunbird-bin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/mozilla-sunbird-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/ChangeLog,v 1.14 2007/01/11 15:54:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/ChangeLog,v 1.15 2007/01/11 16:37:27 armin76 Exp $
+
+*mozilla-sunbird-bin-0.3 (11 Jan 2007)
+
+ 11 Jan 2007; Raúl Porcel <armin76@gentoo.org>
+ -files/app-chrome.manifest-0.2.20050724,
+ -mozilla-sunbird-bin-0.2.20050724.ebuild,
+ -mozilla-sunbird-bin-0.3_alpha2.ebuild, +mozilla-sunbird-bin-0.3.ebuild:
+ Drop old, version bump, fix bugs 159236, 148990
11 Jan 2007; Raúl Porcel <armin76@gentoo.org>
mozilla-sunbird-bin-0.2.20050724.ebuild,
diff --git a/app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3 b/app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3
new file mode 100644
index 000000000000..44951fda77e8
--- /dev/null
+++ b/app-office/mozilla-sunbird-bin/files/digest-mozilla-sunbird-bin-0.3
@@ -0,0 +1,3 @@
+MD5 5474038c9c1944600810ee900b7e20e1 sunbird-0.3.en-US.linux-i686.tar.bz2 7858638
+RMD160 fa9a15521a51f8ba79b8f135333d0c1d06e24de4 sunbird-0.3.en-US.linux-i686.tar.bz2 7858638
+SHA256 1ccacca657eabf8fa371f84780c40f8490e7f802f81f63c3fa2cec4d5e732d44 sunbird-0.3.en-US.linux-i686.tar.bz2 7858638
diff --git a/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3.ebuild b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3.ebuild
new file mode 100644
index 000000000000..6ed63549b9c8
--- /dev/null
+++ b/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/mozilla-sunbird-bin/mozilla-sunbird-bin-0.3.ebuild,v 1.1 2007/01/11 16:37:27 armin76 Exp $
+
+inherit eutils mozilla-launcher multilib
+
+DESCRIPTION="The Mozilla Sunbird Calendar"
+SRC_URI="http://releases.mozilla.org/pub/mozilla.org/calendar/sunbird/releases/${PV}/linux-i686/en-US/sunbird-${PV}.en-US.linux-i686.tar.bz2"
+HOMEPAGE="http://www.mozilla.org/projects/calendar/sunbird.html"
+RESTRICT="nostrip"
+
+KEYWORDS="-* ~x86 ~amd64"
+SLOT="0"
+LICENSE="MPL-1.1 GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="virtual/libc"
+RDEPEND="|| ( ( x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXt
+ )
+ virtual/x11
+ )
+ virtual/xft
+ x86? (
+ >=x11-libs/gtk+-2.2
+ =virtual/libstdc++-3.3
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ >=www-client/mozilla-launcher-1.44"
+
+S=${WORKDIR}/sunbird
+
+pkg_config() {
+ # This is a binary x86 package => ABI=x86
+ # Please keep this in future versions
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
+ has_multilib_profile && ABI="x86"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/opt/sunbird
+
+ # Install sunbird in /opt
+ dodir ${MOZILLA_FIVE_HOME%/*}
+ mv ${S} ${D}${MOZILLA_FIVE_HOME}
+
+ keepdir ${MOZILLA_FIVE_HOME}/extensions # required to run!
+
+ # Create /usr/bin/sunbird-bin
+ install_mozilla_launcher_stub sunbird-bin ${MOZILLA_FIVE_HOME}
+
+ # Install icon and .desktop for menu entry
+ doicon ${FILESDIR}/icon/mozillasunbird-bin-icon.png
+ domenu ${FILESDIR}/icon/mozillasunbird-bin.desktop
+}
+
+pkg_preinst() {
+ declare MOZILLA_FIVE_HOME=/opt/sunbird
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf ${ROOT}${MOZILLA_FIVE_HOME}
+}
+
+pkg_postinst() {
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}